सवाल उबंटू 16.04 - वर्चुअलबॉक्स 5.0 - होस्ट क्रैश


किसी भी अद्यतन के बिना, अचानक जब मैंने वर्चुअलबॉक्स में वीएम पर बिजली देने की कोशिश की, मेजबान मशीन (उबंटू 16.04 चल रहा है) जमा हो गया।

  • मैंने दो बार कोशिश की और समस्या दोहराना जारी रखी।

  • मैं memtest भागो: सब अच्छा है

  • एक ही मुद्दे में एक नया वीएम बनाने की कोशिश की: एक ही मुद्दा।

  • वर्चुअलबॉक्स स्थापना को डाउनग्रेड किया गया: बिल्कुल मदद नहीं की।
  • अक्षम नेटवर्क, साझा फ़ोल्डर्स इत्यादि: कुछ भी नहीं।

उसी मशीन पर मुझे दोहरी बूट में विंडोज 10 भी मिला है। मेरे पास वीबीओक्स और वीएमवेयर में कुछ वीएम हैं। किसी भी एचडब्ल्यू मुद्दे की संभावना को कम करने के लिए, मैंने वहां वीएम शुरू किए और वे ठीक काम करते हैं।

कोई उपाय?

मेजबान को पुनर्प्राप्त करने का एकमात्र तरीका हार्ड-रीसेट करना था।

ps: जैसे ही मैं "स्टार्ट" बटन पर क्लिक करता हूं, फ्रीज होता है।

होस्ट विवरण:

  • वर्चुअलबॉक्स: संस्करण 5.0.40_ उबंटू

  • कर्नेल: 4.13.0-26-जेनेरिक

  • अतिथि: अप्रासंगिक (विंडोज़ 10, ओपनस्यूज, सेंटोस)

  • वर्चुअलबॉक्स की लॉग फ़ाइल खाली है।


17
2018-01-14 15:29


मूल


धन्यवाद और Google का धन्यवाद क्योंकि मुझे आज भी यही समस्या है। और गूगल मुझे यहां आपकी पोस्ट पर निर्देशित करें। वास्तव में यहां अपने काम की सराहना करते हैं। - Clock ZHONG
वही समस्या हल हो गई है: superuser.com/questions/1284705/... - chus


जवाब:


निम्नलिखित के बाद इसे समझ लिया:

https://ubuntuforums.org/showthread.php?t=2382314

(VBox को 5.2 में अपग्रेड करना था और सभी ठीक काम करते थे)

यदि आपको इसकी आवश्यकता है, तो भी इसका पालन करना होगा: वर्चुअलबॉक्स - RTR3InitEx आरसी = -1912 (आरसी = -1912) के साथ असफल रहा सभी पिछली स्थापनाओं को पूरी तरह से अनइंस्टॉल करने के लिए

एक मूक सुरक्षा अद्यतन था जो पूरे होस्ट को लटकाने के लिए पुराने वर्चुअलबॉक्स इंस्टॉलेशन (5.2 से पुराने) का कारण बनता था।


15
2018-01-15 06:56



ओरेकल से 5.2 इंस्टॉल करने के बाद, मुझे वर्चुअलबॉक्स-डीकेएमएस अनइंस्टॉल करना पड़ा और रीबूट करना पड़ा। - Juan Calero
केवल पूरी तरह से वर्चुअलबॉक्स अनइंस्टॉल कर रहा है कुछ के साथ sudo apt-get remove virtualbox*या sudo aptitude remove virtualbox  नया संस्करण स्थापित करने से पहले चाल करेगा। - DJCrashdummy


मैं वास्तव में Sanosay, और Bertrand लो सवाल और जवाब की सराहना करता हूं। मैंने उनका पीछा किया और मेरी स्थिति पर इस मुद्दे को ठीक कर दिया, मुझे संक्षेप में बताएं कि मैंने इस सुविधा के लिए क्या किया है, अपनी सुविधा के लिए यहां चरणबद्ध तरीके से कदम उठाएं:

  1. sudo apt autoremove virtualbox

  2. रीबूट।

  3. जोड़ना deb https://download.virtualbox.org/virtualbox/debian xenial contrib उबंटू 16.04 की सॉफ़्टवेयर स्रोत सूची में।

    ("सॉफ्टवेयर और अपडेट" शुरू करके, और "अन्य सॉफ़्टवेयर" टैब चुनें, और "जोड़ें" बटन पर क्लिक करें, फिर पेस्ट करें deb https://download.virtualbox.org/virtualbox/debian xenial contrib एपीटी लाइन में)

  4. sudo apt update && sudo apt install virtualbox-5.2

    सचेत रहो! आईटी इस virtualbox-5.2 के बजाय virtualbox

  5. स्थापना के बाद, रीबूट करें

  6. वर्चुअलबॉक्स चलाएं, और आप पाएंगे कि आपका वर्चुअलबॉक्स संस्करण अब 5.2 है, और यह एक अतिथि ओएस चलाने पर पूरे होस्ट ubuntu16.04 क्रैश का कारण नहीं बन जाएगा।

Uubuntu16.04 में मूल संस्करण वर्चुअलबॉक्स Ubuntu16.04 नवीनतम पैच के साथ सही ढंग से काम नहीं कर सका, यहां तक ​​कि कैननिकल दावे 16.04 उनके एलटीएस (लॉन्ग टर्म सपोर्ट) संस्करण है, कम से कम यह अब वर्चुअलबॉक्स 5.0 का समर्थन नहीं कर सका।


6
2018-02-04 08:59



वाह फिर से स्थापित करने के बाद फिर से स्थापित करें ... फिर से, और फिर दुर्घटनाग्रस्त हो जाता है। यह पता नहीं लगा सका कि डिफ़ॉल्ट वर्चुअलबॉक्स क्रैश होने पर क्यों रहता है। तब मुझे यह पोस्ट मिला। धन्यवाद!!! - Llewellyn
Llewellyn, यह जानकर मेरी खुशी है कि आपने इस मुद्दे को भी ठीक किया है। यह वास्तव में उबंटू 16.04 एलटीएस में एक बग है, लेकिन उन्हें यह नहीं मिला और इसे ठीक नहीं किया गया, वैसे भी, यह एक मुफ्त ओएस सेवा है, हम कैननिकल टीम को दोष नहीं दे सकते, लेकिन हमें अभी भी व्यावहारिक वर्चुअलबॉक्स की आवश्यकता है। यह Google और StackOverflow वेबसाइटों का मान दिखाता है, वे कैननिकल समर्पित इंजीनियरिंग और सत्यापन टीमों की तुलना में अधिक शक्तिशाली हैं। - Clock ZHONG


इस समस्या में भी भाग गया, उपरोक्त सलाह के लिए धन्यवाद! हालांकि, एक और कदम है जो काम करने के लिए 'उपयुक्त अद्यतन' के लिए गायब है, नई चाबियां, इसे टर्मिनल में पेस्ट करें:

wget -q https://www.virtualbox.org/download/oracle_vbox_2016.asc -O- | sudo apt-key add -
wget -q https://www.virtualbox.org/download/oracle_vbox.asc -O- | sudo apt-key add -

(से https://www.virtualbox.org/wiki/Linux_Downloads)


3
2018-02-16 09:27



कौन कौन से सलाह क्या आप इसका जिक्र कर रहे हैं? सवाल "कोई विचार?" कहता है, निश्चित रूप से सलाह की तरह कुछ नहीं, है ना? यदि यह किसी मौजूदा उत्तर के अतिरिक्त है, इसे और बेहतर बनाने के लिए, तो कृपया अपने उत्तर को संपादित करें कि यह इंगित करने के लिए कि आप किस उत्तर का मतलब है। इसके अलावा: "उपर्युक्त" सापेक्ष है ... यह निर्भर करता है कि मौजूदा उत्तरों को ब्राउज़ करने वाले किसी ने उन उत्तरों को कैसे हल किया है ... - Pierre.Vriens


बिल्कुल इस स्थिति में। और पूरी तरह से अनइंस्टॉल किया गया।

और आधिकारिक वीबी के भंडार जोड़ें:

deb https://download.virtualbox.org/virtualbox/debian xenial contrib

फिर पुन: स्थापित करें। सामान्य के रूप में काम करते हैं।


1
2018-01-26 06:12



मैं सिफारिश करता हूँ संपादित करें यह कैसे करें इसे करने के बारे में विशिष्ट विवरण के साथ इसका विस्तार करने के लिए यह उत्तर। (यह भी देखें मैं एक अच्छा जवाब कैसे लिखूं? सामान्य उबंटू पर किस प्रकार के उत्तरों को सबसे मूल्यवान माना जाता है, इस बारे में सामान्य सलाह के लिए।) - David Foerster
करुणा, मैं समस्या दोहराना नहीं कर सका। ऐसा लगता है कि वर्चुअलबॉक्स चुप अद्यतन से आया था। Sanosay द्वारा वर्णन के रूप में। - Bertrand Lo


आज मैंने पाया कि उबंटू 16.04 में पहले से ही वर्चुअलबॉक्स-5.2 को अपने नवीनतम पैच में शामिल किया गया है: https://download.virtualbox.org/virtualbox/debian xenial / contrib amd64 वर्चुअलबॉक्स-5.2 amd64 5.2.10-122088 ~ उबंटू ~ xenial

तो इसका मतलब है कि हम केवल इसका उपयोग कर सकते हैं:

sudo apt upgrade

इस मुद्दे को सीधे ठीक करने के लिए। शायद कैनोनिकल समर्पित इंजीनियरिंग और सत्यापन टीमों ने भी इस मुद्दे को पाया और यहां हमारी पोस्ट पढ़ी। अब समाधान बहुत आसान है। बस एक पंक्ति कमांड:

sudo apt upgrade

फिर रीबूट करें।


0
2018-04-23 02:50