सवाल मैं नवीनतम wpa_supplicant में अपग्रेड कैसे कर सकता हूं?


मेरे पास (अधिक सटीक, मेरे नियोक्ता के पास) मशीन उबंटू 14.04 एलटीएस चल रही है, जो wpa_supplicant संस्करण 2.1 के साथ आता है। Wpa_supplicant 2.5 में सुधार हैं जो मुझे विश्वास है कि इस मशीन को पीड़ित कुछ वाईफाई मुद्दों के साथ मदद मिल सकती है।

इसके अनुसार dpkg -S, wpa_supplicant में है wpasupplicant पैकेज, लेकिन sudo apt-get upgrade wpasupplicant मुझे बताता है कि मेरे पास पहले से ही नवीनतम संस्करण उपलब्ध है।

क्या कुछ मानक जगह में एक पीपीए है जो मुझे wpa_supplicant को संस्करण 2.5 तक लाने देगा? या स्रोत से निर्माण करना बेहतर है? या क्या मुझे कुछ और करना चाहिए?

(कम कठोर और आक्रामक अपग्रेड प्रक्रिया, हमारे लिए बेहतर: यह मशीन वास्तव में किसी और के परिसर में है और हम इसे केवल वाईफ़ाई के माध्यम से कनेक्ट कर सकते हैं। इसलिए अगर wpa_supplicant को अपग्रेड करने का प्रयास किया गया तो यह दुखी होगा, इसके वाईफाई को तोड़ने का असर पड़ा कनेक्शन। कनेक्टिविटी का एक संक्षिप्त बाधा ठीक है, हालांकि।)


4
2018-02-03 17:04


मूल


अभी भी xenial 2.4 का उपयोग कर रहा है। तो आप इसे किसी भी मानक उबंटू रिपॉजिटरीज़ के माध्यम से नहीं ढूंढ पाएंगे, लेकिन आप इसे कहीं और पा सकते हैं। सबसे खराब स्थिति परिदृश्य आप इसे स्रोत से संकलित कर सकते हैं। यह लिंक आपको उस मार्ग पर कुछ मदद दे सकता है - Mitch
चरण 0, wpa_supplicant के स्रोत के लिए खोज करने से पहले, इसे बनाएं, और इसे स्थापित करने की उम्मीद करें कि यह वाईफाई को तोड़ने और आपकी समस्या को ठीक करने में सक्षम नहीं होगा, आपकी वाईफाई समस्या का निदान करना है। zgrep wlan /var/log/kern.log* दोनों सिरों पर आपको कुछ शुरू करने के लिए कुछ देगा। यह जानने से पहले यादृच्छिक समाधान लागू करना कि समस्या कभी भी समाप्त नहीं होती है। - waltinator
अच्छी सलाह, वॉल्टिनेटर। जैसा भी होता है, समस्या जानने के पहले मैं यादृच्छिक समाधान नहीं लगा रहा हूं; मैंने कुछ डायग्नोस्टिक काम किया है, एक विशिष्ट समस्या और मशीन को पीड़ित कई मुद्दों के लिए जिम्मेदार मानने का अच्छा कारण मिला है, और यह स्थापित किया है कि 2.5 में उस समस्या के लिए एक फिक्स है लेकिन पिछले संस्करणों में नहीं है। मैं इस सवाल में उन विवरणों में नहीं गया क्योंकि मैंने उन्हें प्रासंगिक नहीं माना था। - Gareth McCaughan
(यदि आप उत्सुक हैं, तो देखें lists.infradead.org/pipermail/hostap/2016-February/034640.html समस्या के लिए, lists.infradead.org/pipermail/hostap/2016-February/034641.html जानकारी के लिए कि 2.5 में एक फिक्स है, और lists.infradead.org/pipermail/hostap/2016-February/034646.html wpa_supplicant के मुख्य डेवलपर के लिए यह अपग्रेड करना सुरक्षित होना चाहिए।) - Gareth McCaughan
इसके लायक होने के लिए, मैंने वास्तव में अब तक जो किया है वह है: 2.5 टैरबॉल पकड़ो, उबंटू 14.04 की अपेक्षा करने के लिए इसकी कॉन्फ़िगरेशन फ़ाइल को समायोजित करें, wpa_supplicant को रास्ते से बाहर निकालने के द्वारा स्थान पर अपग्रेड, बिल्ड, और फिर अपग्रेड करें, नया स्थान अपने स्थान पर, और फिर wpa_supplicant प्रक्रिया को मार रहा है। (यह स्वचालित रूप से पुनरारंभ हो जाता है और यह नया है जो चलता है।) कोई बुरा नतीजा स्पष्ट नहीं है, लेकिन निश्चित रूप से हमें बाद में काटने के लिए परेशानी हो सकती है ... - Gareth McCaughan


जवाब: