सवाल Ubuntu 10.10 पर एमपीईजी -4 एएसी और एच .264 डीकोडर कैसे स्थापित करें? [बन्द है]


मैं एक वीडियो चलाने की कोशिश कर रहा हूं जिसके लिए ऊपर उल्लिखित प्लगइन्स की आवश्यकता है। मैंने यहां इस विषय पर कुछ उत्तरों को देखा है लेकिन इसने मेरे लिए इस मुद्दे को हल नहीं किया है।

मैंने अब तक क्या प्रयास किया है:

  1. sudo apt-get install ubuntu-restricted-extras  ... लेकिन इस में कुछ समस्याएं हैं और कुछ पैकेज डाउनलोड करना छोड़ रहा है ... इसलिए पूरी चीज पूरी तरह से डाउनलोड नहीं होती है।

  2. मैंने कोशिश की sudo add-apt-repository "deb http://archive.ubuntu.com/ubuntu $(lsb_release -sc) main universe restricted multiverse"  उपरोक्त भंडारों को उबंटू के स्रोत.सूची में डाउनलोड स्थानों के लिए जोड़ने के लिए, लेकिन इससे मदद नहीं मिली है।

कोई भी जानता है कि मैं यह काम करने के लिए और क्या प्रयास कर सकता हूं?


4
2018-01-02 08:45


मूल


उबंटू 10.10 अब समर्थित नहीं है, कृपया नवीनतम संस्करण 12.10 या 12.04 एलटीएस का उपयोग करें। - Uri Herrera
असमर्थित संस्करण के लिए समर्थन प्राप्त करना मुश्किल है। - Nick Thom
@UriHerrera - क्या आपका मतलब उबंटू 12.10 / 12.04 एलटीएस का ताजा इंस्टॉल है या क्या आपका मतलब है कि मुझे उबंटू के 12.x संस्करणों के लिए कोडेक पैकेज प्राप्त करने की आवश्यकता है? मुझे बाद के मामले में मदद की ज़रूरत होगी क्योंकि मुझे यकीन नहीं है कि उन्हें कहां / कैसे डाउनलोड करें ... - user481913
अपने ओएस को अपग्रेड करें, और इंस्टॉल करें ubuntu-restricted-extras पैकेज। - Uri Herrera
@UriHerrera क्या मैं सिर्फ ओएस को अपग्रेड करने के लिए अद्यतन चला सकता हूं या क्या इसे एक नया इंस्टॉल चाहिए? - user481913


जवाब:


आपको डाउनलोड करना होगा कोडेक्स। मालिकाना स्थापित करने के लिए कोडेक्स टर्मिनल विंडो में निम्न टाइप करें।

sudo apt-get install gstreamer0.10-pitfdll gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse

एक बार इन्हें स्थापित करने के बाद कोडेक्स आप लगभग किसी ऑडियो / वीडियो प्रारूप को चलाने में सक्षम होंगे।

मैं आपको 12.04 एलटीएस में अपग्रेड करने की भी सलाह देता हूं।


4
2018-01-02 09:42



उनमें से सभी में निहित है ubuntu-restricted-extras पैकेज ..., क्या आपने इसका परीक्षण मावेरिक पर किया था? क्या यह आपके लिए मावेरिक पर काम किया? - Uri Herrera
हाँ यह Maverick पर काम किया .. - Mukund
@ मुकुंद - मैंने 32 बिट संस्करण के लिए कमांड की कोशिश की, हालांकि मुझे निम्नलिखित त्रुटियों का सामना करना पड़ा। 1) समस्याएं हैं और इसका उपयोग बिना बल-हां के किया गया था। इसलिए मैंने --force-yes के साथ प्रतिस्थापित किया और फिर कोशिश की ... इस बार कुछ संकुल डाउनलोड करने में समस्या है I.e मुद्दा संख्या। 2 2) लाने में विफल archive.ubuntu.com/ubuntu/pool/multiverse/g/...  404 नहीं मिला [आईपी: xxx.xxx.xxx.xxx 80] रनिंग एपीटी-अपडेट अपडेट या --फिक्स-लापता होने का प्रयास करें। तो आगे क्या ? - user481913