सवाल पाइप इंस्टॉल का उपयोग कर पायथन 3.2 के लिए अनुरोध मॉड्यूल कैसे स्थापित करें?


मेरे पास पाइथन 2.7 और 3.2 के साथ उबंटू 12.04 है
निम्नलिखित यह पन्ना मैंने अनुरोध मॉड्यूल स्थापित किया।

$ sudo pip install requests

हालांकि, यह केवल पायथन 2 के लिए काम करता है लेकिन पायथन 3 नहीं:

$ python
Python 3.2.3 (default, Apr 10 2013, 06:11:55) 
[GCC 4.6.3] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import requests
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: No module named requests
>>> 

मुझे अनुरोध मॉड्यूल कैसे स्थापित करना चाहिए ताकि यह मेरे पायथन संस्करण दोनों के लिए काम कर सके?


4
2017-09-30 18:32


मूल




जवाब:


ओपी द्वारा उत्तर दिया गया:

मैंने इसे विभिन्न उत्तरों का पालन करके समझ लिया    यहाँ।   जवाब है कि मुझे पहले पाइप-3.2 स्थापित करना होगा। मुझे यकीन नहीं है   हालांकि सभी कदम जरूरी हैं:

$ sudo apt-get install python3-pip
$ sudo apt-get install python3-setuptools
$ sudo python3 -m easy_install pip
...
Installing pip script to /usr/local/bin
Installing pip-3.2 script to /usr/local/bin
.. Now I get pip-3.2:

$ sudo pip-3.2 install requests

4