सवाल ग्रहण केप्लर ग्रहण में पाईडेव नहीं मिला है, यह कहता है कि यह सही ढंग से स्थापित है


मुझे लगता है कि यह एक जैसी समस्या है यह प्रश्न, लेकिन मुझे एक अलग सवाल दर्ज करने के लिए कहा गया था, क्योंकि मेरी समस्या पायथन -3 से संबंधित है।

स्थिति: उबंटू 12.04 64 बिट, पायथन 3.2.3, ग्रहण (केप्लर) और पायडेव स्थापित करना।

समस्या: PyDev को कॉन्फ़िगर नहीं कर सकता, पाइथन प्रोजेक्ट नहीं बना सकता है। विंडोज 7 पर एक ही प्रक्रिया ठीक काम करता है।

मैंने दिशानिर्देशों का पालन किया http://pydev.org/manual_101_install.html, लेकिन न तो "नया सॉफ्टवेयर स्थापित करें" और न ही "ग्रहण बाज़ार" के माध्यम से काम किया, यानी मुझे विंडो / प्राथमिकताओं में कोई पायथन या पायडेव प्रविष्टि दिखाई नहीं दे रही है। खैर, ऐसा लगता है कि स्थापित किया गया है, क्योंकि एक्लिप्स कहते हैं, "पहले से इंस्टॉल है", अगर मैं इसे फिर से स्थापित करने का प्रयास करता हूं।

कमांड लाइन पायथन से काम कर रहा है:

$ python
Python 3.2.3 (default, Sep 25 2013, 18:22:43) 
[GCC 4.6.3] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>>

मैंने लिंक करने की कोशिश की python सेवा मेरे python2.7 में /usr/bin लेकिन बिना किसी प्रयास के।

क्या किसी के पास अभी तक कोई विचार है?

संपादित करें:  java -version कहते हैं "1.6.0_27"

Eclipse Marketplace with PyDev installed


4
2017-11-16 18:47


मूल


मुझे मैक ओएस एक्स 10.8.5 और पायथन 2.7.6 पर बिल्कुल वही समस्या मिली है, इसलिए मुझे लगता है कि यह उबंटू से ग्रहण / pydev से अधिक समस्या है।
उबंटू और मैकोज़ दोनों डेबियन पर आधारित हैं, इसलिए वास्तव में एक कनेक्शन हो सकता है। एक दोस्त ने जावा संस्करण को देखने की सिफारिश की। यह यहां 1.6.0_27 है। क्या वह समस्या का हिस्सा हो सकता है? - Christoph Jüngling
क्या आपके पास कोई टूटी हुई डाउनलोड है ?? - Sukupa91


जवाब:


मेरे पास आपकी ही समस्या और विन्यास है। जावा v1.7 का उपयोग कर स्विच करने के बाद

sudo update-alternatives --config java

सबसे पहले आप PyDev परिप्रेक्ष्य नहीं देख सकते हैं, लेकिन सिर्फ एक पायथन परियोजना आयात / बनाएँ और यह काम करता है।


3
2017-11-29 09:26





आप PyDev v3 को काम करने और अपने वर्तमान जावा इंस्टॉल संस्करण को बनाए रखने के लिए जावा 7 स्थापित कर सकते हैं और कमांड लाइन-वीएम विकल्प का उपयोग करके कौन सी जेवीएम ग्रहण का उपयोग करना चाहिए, यह निर्दिष्ट करके अपने वर्तमान सेट को प्रभावित नहीं कर सकते हैं।

सब यहाँ समझाया गया है


1
2017-11-29 19:08



यहां भी देखें: stackoverflow.com/q/19838294/911550 - parvus