सवाल मैं एएमडी कावेरी मशीन पर fglrx कैसे स्थापित करूं?


मैंने हाल ही में एक कावेरी मशीन बनाई है, लेकिन मुझे fglrx ड्राइवरों को चलाने और चलाने में परेशानी हो रही है। मैं उन्हें स्थापित कर सकता हूं, लेकिन लाइटडीएम स्क्रीन बस काला हो जाएगी।

मशीन में एएमडी ए 10-7850 के एपीयू और एक एसस ए 88 एक्सएम प्लस मदरबोर्ड है। मैंने उबंटू 13.10 और 14.04 दोनों का उपयोग करके परीक्षण किए हैं। अंत में मुझे या तो उपयोग करने में कोई फर्क नहीं पड़ता।

मैंने निम्नलिखित कोशिश की है:

  • नियमित fglrx- अद्यतन स्थापित करें -> कोई परिणाम नहीं
  • Xorg-edgers पीपीए स्थापित करें -> कोई परिणाम नहीं
  • मैन्युअल रूप से आधिकारिक एएमडी बीटा संस्करण के माध्यम से स्थापित करें यह सीएचटीएमएल गाइड -> कोई परिणाम नहीं
  • सभी कर्नेल हटाएं और 3.12 कर्नेल को इंस्टॉल करें मेनलाइन पीपीए, और उस कर्नेल के खिलाफ आधिकारिक एएमडी बीटा संस्करण स्थापित करें -> कोई परिणाम नहीं

यह संभव होना चाहिए, क्योंकि फोरोनिक्स ने उसी श्रृंखला के थोड़ा अलग मदरबोर्ड पर सटीक उसी एपीयू के खिलाफ एफजीआरआरएक्स का परीक्षण किया है, सिवाय इसके कि उन्होंने इंस्टॉलेशन बिट पर कोई निर्देश नहीं दिया था।

किसी भी मदद का स्वागत है, क्योंकि इंटरनेट वर्तमान में एक बंजर रेगिस्तान है जब यह लिनक्स पर एएमडी के नए एपीयू की बात आती है।


4
2018-01-22 12:59


मूल


लॉग फाइलों की सामग्री क्या है? /var/log/Xorg.0.log? - Braiam
आपके पास वही सेटअप है जो मैं करता हूं। और दुख की बात है मेरे पास एक फॉलो-अप प्रश्न है - जब आपने प्रयोग किया था तो शायद आपने मेरी तरह समस्या देखी है? - Mołot


जवाब:


समस्या सुलझ गयी। एएमडी ने लिनक्स के लिए ए10-7850 के समर्थन के साथ अपने उत्प्रेरक 14.1 ड्राइवर को जारी किया। ध्यान दें कि यह एक बीटा चालक है, और यह पहले से ही है। हालांकि, मुझे जो प्रदर्शन मिला है वह ठीक है। ट्राइन 2, डोटा 2, माइनक्राफ्ट (ओपनजेडीके 7), यूरोपा यूनिवर्सलिस IV और आईकरस ऑनलाइन की बंदूकें सभी माध्यम / उच्च सेटिंग्स के साथ 1920x1080 पर काफी अच्छी तरह से चल रही थीं।

निर्देश:

  1. डाउनलोड एएमडी से चालक
  2. फ़ाइल को अनजिप करें।
  3. नई फाइल निष्पादन योग्य बनाओ। sudo chmod u+x amd-driver*.run चाल करना चाहिए
  4. पूर्वापेक्षाएँ स्थापित करें: sudo apt-get install cdbs dh-make dkms execstack dh-modaliases linux-headers-generic libqtgui4 lib32gcc1
  5. इंस्टॉलर से .deb फ़ाइलें बनाएं: sudo ./amd-driver*.run --buildpkg Ubuntu/saucy  लागू होने पर अपने संस्करण के साथ उबंटू / सॉसी बदलें। एएमडी का कहना है कि यह उबंटू 12.04 के साथ भी संगत है, इसलिए आप डाल देंगे --buildpkg Ubuntu/precise अतं मै।
  6. वास्तविक स्थापना बिट करें: sudo dpkg -i fglrx*.deb  यह एकाधिक .debs स्थापित करता है।
  7. वैकल्पिक-आईएसएच, अपने कंप्यूटर को पुनरारंभ करने के बाद xorg.conf फ़ाइल प्रारंभ करें: sudo amdconfig --initial -f

और वही जो है।


4
2018-02-07 18:12



मैंने आज कोशिश की और जोड़ने की जरूरत है xserver-xorg-dev इसे ठीक से काम करने के लिए चरण 4 में संकुलों की सूची में। - Mołot