सवाल रुबी 1.9.3 के साथ उबंटू 12.04 में rubygems कैसे स्थापित करें


तो मैंने इन आदेशों का उपयोग किया:

sudo apt-get install ruby 1.9.3
cd /etc/alternatives
sudo ln -sf /usr/bin/ruby1.9.3 ruby

से https://stackoverflow.com/questions/11078166/how-do-i-install-ruby-1-9-3-on-ubuntu-without-rvm रूबी 1.9.3 पाने के लिए और इसे डिफ़ॉल्ट बनाते हैं। ऐसा लगता है कि ठीक काम किया है।

अब जब मैं मणि इंस्टॉल करने का प्रयास करता हूं तो यह मुझे बताता है कि रत्न पहले से ही नवीनतम हैं। हालांकि, जब मैं एक स्क्रिप्ट चलाने का प्रयास करता हूं तो यह मुझे बताता है कि मुझे पहली पंक्ति पर आवश्यक मणि नहीं मिल रहा है। लंबी कहानी छोटी, इस स्क्रिप्ट ने कोड में आगे की त्रुटि के कारण रूबी 1.8.7 में काम नहीं किया, लेकिन बिना किसी समस्या के लाइनों की आवश्यकता होती है।

इसलिए मुझे उम्मीद थी और मुझे लगता है कि मुझे अपने सभी 1.8.7 रत्नों को 1.9.3 के लिए पुनर्स्थापित करने की आवश्यकता है या कम से कम यह पता लगाना है कि मैंने इंस्टॉल किए गए रत्नों पर 1.9.3 कैसे इंगित किया है।

मैं 1.9.3 के लिए उपयोग करने योग्य रत्न कैसे प्राप्त करूं?


4
2018-04-13 15:42


मूल


आप के पहले भाग का उपयोग कर सकते हैं यह जवाब। - NickKolok


जवाब:


क्या आपके पास ruby1.8 और rubygems भी स्थापित हैं? उन्हें अनइंस्टॉल करें, या कम से कम rubygems ("sudo apt-get rubygems हटाएं")। उबंटू 12.04 के ruby1.9.3 पैकेज में rubygems का एक संस्करण शामिल है, कोई अतिरिक्त पैकेज आवश्यक नहीं है।


4
2017-07-31 15:38



जवाब के लिए धन्यवाद। इस बिंदु पर मैं आरवीएम में गया हूं और सबकुछ इसका उपयोग करके काफी अच्छा काम करता है। अगर कोई इसका परीक्षण करता है और कहता है कि यह काम करता है, तो मैं इसे उत्तर के रूप में चिह्नित करूंगा। मेरे पास बस इसके साथ गड़बड़ करने का समय नहीं है और काम करने वाली चीज़ों को तोड़ने का जोखिम है। एक बार फिर धन्यवाद। - Gabe Spradlin