सवाल उबंटू 14 पर MySQL वर्कबेंच


हाय मैंने अभी तक का नवीनतम संस्करण स्थापित किया है उबंटू, 14, और अब मुझे MySQL वर्कबेंच स्थापित करने की आवश्यकता है।

मैं mysql साइट से .deb पैकेज डाउनलोड करता हूं लेकिन जब मैं इसे स्थापित करने का प्रयास करता हूं तो मुझे यह त्रुटि प्राप्त होती है:

Preparing to unpack .../mysql-workbench-community-6.1.4-1ubu1310-amd64.deb ...
Unpacking mysql-workbench-community (6.1.4-1ubu1310) ...
dpkg:dependency problems prevent configuration of mysql-workbench-community:
 mysql-workbench-community depends to mysql-client; however:
  The mysql-client package didn't install.

dpkg: error processing package mysql-workbench-community (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.54ubuntu1) ...
Processing triggers for shared-mime-info (1.2-0ubuntu3) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Errors were encountered while processing:
 mysql-workbench-community

मैं दौड़ने की कोशिश करता हूँ sudo apt-get -f install तथा sudo apt-get update, मैं मैन्युअल रूप से निर्भरता स्थापित करने की कोशिश करता हूं लेकिन काम नहीं करता था।

क्या आप मेरी मदद कर सकते हैं?

धन्यवाद

संपादित करें:

I ran: `dpkg --get-selections | grep mysql`

और मुझे यह मिलता है:

libdbd-mysql-perl               install
libmysqlclient18:amd64              install
mysql-client-5.6                install
mysql-client-core-5.6               install
mysql-common                    install
mysql-common-5.6                install
mysql-server-5.6                install
mysql-server-core-5.6               install
mysql-workbench-community           deinstall

4
2018-04-27 09:27


मूल


आपको पहले mysql-client इंस्टॉल करना होगा। sudo apt-get install mysql-client - Hamed Kamrava
हाँ मैंने इसे पहले स्थापित किया था - Teo
लेकिन आपका त्रुटि लॉग कहता है The mysql-client package didn't install. सुनिश्चित करें कि यह पैकेज सफलतापूर्वक स्थापित है। - Hamed Kamrava
मैं इसे अभी चलाता हूं: sudo apt-mysql-client-5.6 स्थापित करें लेकिन मुझे प्राप्त होता है: mysql-client-5.6 पहले से ही नवीनतम संस्करण है। - Teo


जवाब:


मैंने इस तरह हल किया:

1) unistall mysql-server

2) mysql-workbench के बारे में सभी विन्यास हटाएं

3) mysql साइट पर .tar.gz का उपयोग करने के बजाय, मैं सभी सॉफ्टवेयर केंद्र द्वारा स्थापित करता हूं।

अब यह काम कर रहा है..


4
2018-04-27 11:04



इसके अलावा / usr / share / mysql-workbench, मैं और कहां कॉन्फ़िगरेशन फ़ाइलों को ढूंढ सकता हूं? अभी भी mysql 5.6 स्थापित के साथ वर्कबेंच स्थापित करने में असमर्थ। - Dylan Pierce
एक कमांड चलाएं जैसे: सुडो ढूंढ / -नाम mysql-workbench - Teo