सवाल ubuntu 16.04 पर xpra संस्करण


जब मैंने अपने कंप्यूटर को उबंटू 16.04 में अपडेट किया है, तो xpra पैकेज v0.15.8 पर अपडेट किया गया है।

मेरे पास इस संस्करण के साथ कुछ संगतता समस्याएं हैं I मैंने पढ़ा है कि v0.15.x एक असमर्थित संस्करण है और v0.14.x वर्तमान एलटीएस (दीर्घकालिक समर्थन) रिलीज है (https://www.xpra.org/trac/wiki/Versions)।

मैं ubuntu 16.04 पर xpra V0.14.x कैसे स्थापित कर सकता हूं?


4
2017-09-05 11:13


मूल




जवाब:


0.14.x को अपडेट करने से मुझे अभी भी xpra लॉन्च करने की अनुमति नहीं मिली है, लेकिन नवीनतम शाखा 2.0.x को अपडेट किया गया है।

टीएल; डीआर ने मेरी प्रतिलिपि बनाई ब्लॉग:

# Administrator privileges
sudo su -

# Import the packager's key:
apt-get install curl
curl http://winswitch.org/gpg.asc | apt-key add -

# Xenial Xerus (16.04)
echo "deb http://winswitch.org/ xenial main" > /etc/apt/sources.list.d/winswitch.list;
apt-get install software-properties-common >& /dev/null;
add-apt-repository universe >& /dev/null;
apt-get update;
apt-get install winswitch

6
2018-03-20 10:21



माफ करना, मैं नहीं जानता था। किया हुआ :) - brtknr


टर्मिनल खोलें और टाइप करें:

cd Desktop/
wget -c http://xpra.org/dists/xenial/main/binary-amd64/xpra_0.14.35-1_amd64.deb # official deb package from xpra.org
sudo dpkg -i xpra_0.14.35-1_amd64.deb  

xpra v0.14.x वर्तमान एलटीएस (दीर्घकालिक समर्थन) रिलीज है, और xpra_0.14.35-1_amd64.deb उबंटू 16.04 के साथ संगत है।

यदि सॉफ़्टवेयर अद्यतन करते समय आपको टूटा पैकेज संदेश मिलता है, तो इस आदेश का उपयोग करके xpra को हटा दें:

sudo dpkg -r xpra  

यदि आपको सॉफ़्टवेयर अपडेट करते समय भी एक टूटा पैकेज संदेश मिलता है, तो यह xpra की गलती नहीं थी। Xpra इंस्टॉल करने से पहले आपको टूटे हुए संकुल त्रुटि संदेश को हल करने की आवश्यकता है। हालांकि इसे एक अलग प्रश्न के रूप में पूछा जाना चाहिए।


0
2017-09-05 11:23



धन्यवाद लेकिन अब सिनैप्टिक पैकेज मैनेजर मुझे बताता है कि मेरे पास एक त्रुटि है (टूटा हुआ पैकेज) और मैं सॉफ्टवेयर अपडेट इंस्टॉल नहीं कर सकता। - Mikel Antoñana