सवाल उबंटू द्वारा समर्थित ऑप्टिमस टेक्नोलॉजी के साथ एक एनवीआईडीआईए जेफफोर्स है?


मैं डेल एक्सपीएस 15 लैपटॉप खरीदने पर विचार कर रहा हूं। लैपटॉप में एक एनवीडिया 420 मीटर कार्ड है जो लिनक्स के साथ काम करना चाहिए लेकिन मैं पढ़ता रहता हूं कि लिविंग पर एनवीडिया ऑप्टिमस तकनीक समर्थित नहीं है। मुझे शक्ति बचाने के लिए एनवीडिया से इंटेल में स्विच करने में वास्तव में दिलचस्पी नहीं है, लेकिन यह जानने की जरूरत है कि अगर मैं उबंटू स्थापित करता हूं तो वास्तव में एनवीडिया कार्ड काम करेगा।

अगर किसी को ऑप्टिमास टेक्नोलॉजी के साथ एनवीडिया कार्ड का उपयोग करने का अनुभव है या सवाल में सटीक लैपटॉप भी बेहतर है (1 जीबी एनवीआईडीआईए जेफफोर्स जीटी 420 एम के साथ डेल एक्सपीएस 15) यह बहुत अच्छा होगा।

लिनक्स को अपनाने से लोगों को वापस लाने में एक बड़ी समस्या इस प्रकार की हार्डवेयर समस्या है। मैं एक दीर्घकालिक उबंटू उपयोगकर्ता और समर्थक हूं जो इस तरह की खरीद के साथ गलती नहीं कर सकता। मैं यह जानने के लिए £ 500 + खर्च नहीं करना चाहता हूं कि मेरे पास कोई ग्राफिक्स त्वरण नहीं है क्योंकि विंडोज 7 एक विकल्प नहीं है।


168
2018-04-25 10:32


मूल


हालात थोड़ा सा सुधार कर सकते हैं कि हाइब्रिड ग्राफिक्स समर्थन के लिए एक ब्लूप्रिंट है: blueprints.launchpad.net/ubuntu/+spec/desktop-p-hybrid-graphics लेकिन मैं विंडोज़ में समर्थित स्तर के लिए पूरी तरह से समर्थित होने की उम्मीद नहीं करता। - 719016
यहां लाइव डेमो अवलोकन है: youtube.com/watch?v=6ki7PLcXo00 - Vitaliy Kulikov
CUDA Bumblebee के साथ बहुत अच्छी तरह से काम करता है। मैं ब्लेंडर में जीपीयू प्रतिपादन का उपयोग कर रहा हूँ।
"लिनक्स को अपनाने से लोगों को वापस लाने में एक बड़ी समस्या इस प्रकार की हार्डवेयर समस्या है।" दोहराने लायक है। - sequoia mcdowell
क्या यह काम करेगा? phoronix.com/scan.php?page=news_item&px=MTM0NzE - MiJyn


जवाब:


भले ही ड्राइवर डाउनलोड पेज पर समर्थित उत्पाद टैब कहते हैं कि जीटी 420 एम समर्थित है, ऑप्टिमस वेरिएंट हैं नहीं समर्थित। अतिरिक्त सूचना टैब से:

समर्थित जीपीयू को शामिल करने वाले कुछ डिज़ाइन एनवीडिया लिनक्स ड्राइवर के साथ संगत नहीं हो सकते हैं: विशेष रूप से, स्विचबुक (हाइब्रिड) या ऑप्टिमस ग्राफिक्स के साथ नोटबुक और ऑल-इन-वन डेस्कटॉप डिज़ाइन काम नहीं करेंगे यदि हार्डवेयर में एकीकृत ग्राफिक्स को अक्षम करने का अर्थ उपलब्ध नहीं है ।

इस ऑप्टिमस डिज़ाइन का अर्थ है कि असतत एनवीडिया कार्ड एकीकृत इंटेल जीपीयू में वायर्ड है और यह मॉनीटर से बिल्कुल जुड़ा नहीं है। कुछ हाइब्रिड ग्राफिक्स लैपटॉप आपको अभी भी BIOS में Nvidia कार्ड चुनने की अनुमति देते हैं, लेकिन अधिकांश आधुनिक ऑप्टिमस लैपटॉप में यह विकल्प नहीं है।

मैं अनुभव से बात कर रहा हूं, मेरे पास एक GT425M है जो i5-460M प्रोसेसर के साथ संयुक्त है। यदि कार्ड को स्विच / अक्षम करने के लिए कोई BIOS या हार्डवेयर सेटिंग नहीं है, तो आप अपना पैसा निकाल रहे हैं। एक्सपीएस 15 परिवार में इनमें से कोई भी विशेषता नहीं है। यद्यपि आप इंटेल ग्राफिक्स कार्ड का उपयोग करने में सक्षम हैं, आप एनवीडिया कार्ड का भी उपयोग करना चाह सकते हैं क्योंकि आपने इसके लिए भुगतान किया है जो इस समय सीधे संभव नहीं है।

आप ऑप्टिमस के बिना एक और लैपटॉप की तलाश करेंगे। ऑप्टिमस बकवास है और एनवीडिया लिनक्स के लिए बेहतर समर्थन प्रदान करने से इंकार कर देता है। यदि आप साहसी हैं और ऐसी नोटबुक खरीदते हैं, तो जाएं लिनक्स हाइब्रिड ग्राफिक्स ब्लॉग और इसकी सदस्यता लें लॉन्चपैड मेलिंग सूची। उनके पास जाओ विकि इस तरह के एक कार्ड (उम्मीद है) काम करने के विभिन्न तरीकों के लिए। एक विधि कहा जाता है भंवरा जो आपको अपने एनवीडिया कार्ड पर प्रोग्राम प्रस्तुत करने की अनुमति देता है। मैं वर्तमान में अन्य समाधानों पर इसकी अनुशंसा करता हूं (प्रकटीकरण: मैं इसका डेवलपर हूं)।

उबंटू 12.10 क्वांटल को हाइब्रिड ग्राफिक्स लैपटॉप के लिए वास्तविक समर्थन के लिए पहली बिट्स के साथ भेज दिया जाएगा, जिसे प्राइम कहा जाता है। यह अत्यधिक प्रयोगात्मक और विकास में है और शायद कई लोगों के लिए पर्याप्त स्थिर नहीं है। हालांकि, ओपन-सोर्स ग्राफिक्स ड्राइवर केवल इसका समर्थन करते हैं भविष्य में एनवीडिया भी समर्थन जारी कर सकता है अगर यह उनके लिए बहुत अधिक काम नहीं हैयह पन्ना क्वांटल के लिए हाइब्रिड ग्राफिक्स समर्थन ट्रैक करता है, ये रियरिंग के लिए ब्लूप्रिंट हैं

यदि आपने nvidia.com से ड्राइवर स्थापित किया है

आपने ड्राइवरों को स्थापित करके एक बड़ी गलती की है सीधे nvidia.com से। यदि आप नए ड्राइवर रखना चाहते हैं, तो जोड़ें ubuntu-x-swat/x-updates पीपीए क्योंकि ये एनवीडिया ड्राइवरों को इस तरह से स्थापित करेंगे कि आपका ऑप्टिमस सिस्टम मर नहीं जाता है।

Nvidia.com से nvidia ड्राइवर स्थापित करने के बाद, आप सभी ग्राफिक्स प्रभाव, ब्लैक स्क्रीन या बहुत धीमी ग्राफिक्स प्रदर्शन के नुकसान का अनुभव कर सकते हैं। स्थापना रद्द करने के निर्देश:

  1. पकड़े हुए वसूली मोड में बूट करें खिसक जाना बूटिंग और रिकवरी विकल्प के लिए चुनने से पहले
  2. निम्नलिखित मेनू में, के लिए चुनें netroot
  3. अनइंस्टॉल एनवीडिया:

    nvidia-uninstall
    
  4. एनवीडिया द्वारा उत्पन्न विन्यास फाइल को हटा दें यदि कोई है:

    rm /etc/X11/xorg.conf
    
  5. जीएल के लिए मेसा पैकेज को पुनर्स्थापित करें:

    apt-get --reinstall install libgl1-mesa-glx
    
  6. पूरा होने पर, रीबूट करें:

    reboot
    

बम्बेबी के लिए स्थापना निर्देश

यदि आपने पहले बम्बलबी या आयरनहाइड स्थापित किया है, तो निर्देशों की जांच करना सुनिश्चित करें http://wiki.bumblebee-project.org/Upgrading-on-Ubuntu

चूंकि बम्बलबी संस्करण 3.0 "टम्बलवेड" के बाद से, यह एनवीडिया कार्ड को सुरक्षित तरीके से अक्षम कर सकता है बिजली बचाएँ (प्रेस विज्ञप्ति)। आप बेहतर प्रदर्शन के लिए असतत कार्ड का उपयोग कर प्रोग्राम भी चला सकते हैं। स्थापाना निर्देश:

  1. ब्रह्मांड और विविध विविध भंडार सक्षम करें Nvidia चालक के लिए। 1. (13.10 सॉसी के लिए वैकल्पिक) हालिया ड्राइवरों वाला एक पीपीए जोड़ें क्योंकि रिपॉजिटरीज़ में से एक संभवतः पुराना है:

    sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
    
  2. (13.04 के लिए दुर्लभ और पहले, सॉसी और बाद में आवश्यक नहीं) स्थिर बम्बलबी रिलीज पीपीए जोड़ें:

    sudo add-apt-repository ppa:bumblebee/stable
    sudo apt-get update
    
  3. स्वामित्व Nvidia ड्राइवर का उपयोग कर Bumblebee स्थापित करें:

    sudo apt-get install bumblebee bumblebee-nvidia linux-headers-generic
    
  4. समूह परिवर्तन लागू करने के लिए रीबूट या पुनः लॉगिन करें

यदि आप अब एनवीडिया कार्ड पर एक प्रोग्राम चलाने के लिए चाहते हैं, तो इसका उपयोग करें optirun कार्यक्रम:

optirun firefox &

यदि आप केवल बिजली बचत में रूचि रखते हैं, तो अंतिम चरण को चरण 4 में प्रतिस्थापित करें:

sudo apt-get install --no-install-recommends bumblebee linux-headers-generic

बाद में, आप अभी भी इंस्टॉल करके एनवीआईडीआईए का उपयोग कर सकते हैं bumblebee-nvidia। यदि आप 32-बिट प्रोग्राम का उपयोग करना चाहते हैं, तो आप अभी भी आवश्यक पुस्तकालयों को स्थापित कर सकते हैं sudo apt-get install virtualgl-libs-ia32। आप है लिनक्स-हेडर-जेनेरिक जोड़ने के लिए, अन्यथा पावर सेविंग मॉड्यूल bbswitch बनाया नहीं जा सकता

वर्चुअलग्ल के बजाय, आप भी कोशिश कर सकते हैं primus बेहतर प्रदर्शन प्राप्त करने के लिए। पैकेज का नाम है primus और आप इसका उपयोग कर सकते हैं:

primusrun glxgears
# alternative that is nearly the same:
optirun -b primus glxgears

(नोट: 60 एफपीएस सीमा के बारे में पूछने से पहले, कृपया पढ़ें इसके एफएक्यू।)

यह भी देखें https://wiki.ubuntu.com/Bumblebee

टिप्पणियाँ:

  • का उपयोग करते हुए acpi_call मैन्युअल रूप से बहिष्कृत है। डिफ़ॉल्ट रूप से, यह निलंबित जीवित नहीं रहेगा।
  • प्रयोग नहीं करें ppa:mj-casalogic/bumblebee या श्रीमेई / बम्बेबी-ओल्ड-एंड-छोड़े गए गिट, इसे अब और बनाए रखा नहीं गया है और इसमें कई त्रुटियां हैं।
  • मार्टिन जुहल ने मूल बम्बलबी को आयरनहाइड में फेंक दिया, लेकिन मेरी राय में इसका उपयोग नहीं किया जाना चाहिए क्योंकि मूल बम्बलबी से डिज़ाइन त्रुटियां अभी भी मौजूद हैं और "पावर प्रबंधन" सुविधाएं स्थिर नहीं हैं (गलत तरीके, _ON और _OFF, का उपयोग किया जाता है )। स्थापना अभी भी एक गड़बड़ है, इसे हटाने के बाद आपकी स्थापना टूटा जा सकता है।

यदि आप एनवीडिया कार्ड और न ही बम्बलबी का उपयोग नहीं करना चाहते हैं

यदि आपने गलती से एनवीडिया ड्राइवर स्थापित किया है (यानी जॉकी का उपयोग करके), तो आपके पास दो विकल्प हैं:

  • ड्राइवर को अनइंस्टॉल करें (पैकेज nvidia-current)
  • जैसा कि वर्णन किया गया है डिफ़ॉल्ट ओपनजीएल पुस्तकालयों को सेट करें यह बग्रेपोर्ट

158
2018-01-21 03:33



@JorgeCastro Bumblebee केवल तभी जरूरी है जब आप एनवीडिया कार्ड का उपयोग करना चाहते हैं। यदि आप एनवीडिया ड्राइवर स्थापित नहीं करते हैं, तो इंटेल कार्ड ठीक काम करेगा। - Lekensteyn
@ जॉर्ज कैस्ट्रो यह सही है, काम करने वाले ग्राफिकल डेस्कटॉप के लिए कोई और कार्रवाई आवश्यक नहीं है। बस लोगों को बताएं कि एनवीडिया ड्राइवर स्थापित न करें। यदि वे पहले से ही कर चुके हैं, तो उन्हें इसे हटा देना चाहिए। - Lekensteyn
ऊर्जा खपत के बारे में क्या? क्या बम्बलबी निष्क्रिय (एनवीडिया) जीपीयू को बंद करने में सक्षम नहीं है? AFAIK यह अभी भी सक्रिय होगा और अगर आप "जॉकी को अनदेखा करें" मार्ग पर जाते हैं (जो कम से कम लोगों को अपने सिस्टम के साथ काम करने में सक्षम बनाता है, तो यह बहुत बुरा नहीं है :))। - htorque
@htorque Bumblebee कार्ड चालू / बंद करने में सक्षम है, लेकिन यह एक प्रयोगात्मक विशेषता है जिसके लिए आपको कामकाजी कॉल पता है। यदि आपके पास ट्विटर है, तो मुझे फ़ॉलो करें (लेकेनस्टीन) या Team_Bumblebee को सूचित करने के लिए जब बम्बलबी के पास सही कॉल का पता लगाने के लिए स्वचालित तरीका है। - Lekensteyn
@ htorque Bumblebee 3.0 के साथ, कार्ड का उपयोग कर अक्षम किया जा सकता है bbswitch। - Lekensteyn


उबंटू 12.10 के रूप में अपडेट करें:

ग्राफिक्स स्टैक के सभी टुकड़े हाइब्रिड ग्राफिक्स का समर्थन करने के लिए आवश्यक है। इसे 1210 में बनाया गया है; क्वांटल क्विज़ल में हाइब्रिड ग्राफिक्स के लिए समर्थन करने के लिए आधारभूत संरचना है - दोनों प्रदर्शन को विस्तारित करने के लिए जब बाहरी मॉनीटर केवल अलग चिप द्वारा संचालित किए जा सकते हैं, और अलग चिप पर अनुप्रयोग चलाने और एकीकृत जीपीयू पर प्रदर्शित करने के लिए।

हालांकि, दो चेतावनी हैं, एक बड़ा, एक नाबालिग।

मामूली चेतावनी यह है कि कोई जीयूआई समर्थन नहीं है - असतत जीपीयू पर आवेदन चलाने का कोई स्पष्ट तरीका नहीं है। आप इसे सेट करके कर सकते हैं DRI_PRIME=1 एक आवेदन शुरू करने से पहले पर्यावरण चर।

प्रमुख चेतावनी यह है कि यह केवल मुफ्त ड्राइवरों पर लागू होता है - nouveau, radeon, तथा intel। एनवीडिया ने अब लिनक्स पर हाइब्रिड ग्राफिक्स का समर्थन करने में रुचि व्यक्त की है, लेकिन dma-buf कर्नेल प्रतीकों को जिन्हें वे उपयोग करने की आवश्यकता है उन्हें जीपीएल के रूप में चिह्नित किया जाता है, जिनका उपयोग वे नहीं करेंगे।

इसके अतिरिक्त हाइब्रिड समर्थन में केवल प्रकाश परीक्षण देखा गया है, और अभी भी ऐसे टुकड़े हैं जो कार्यान्वित किए जा रहे हैं, जैसे फायरिंग को रोकने के लिए जीपीयू में सिंक्रनाइज़ेशन।

उबंटू 12.04 एलटीएस के रूप में स्थिति:

एनवीडिया की आधिकारिक स्थिति यह है कि उनके पास लिनक्स पर ऑप्टिमस का समर्थन करने की कोई योजना नहीं है - हमारे ग्राफिक्स स्टैक को एक धारणा के साथ इंजीनियर किया गया है कि केवल एक कार्ड एक दिए गए डिस्प्ले को चला रहा है, और आसपास काम करना आसान नहीं है।

डेव एयरली एक्स सर्वर और कर्नेल में इसे उलझाने में बहुत सारे काम किए हैं, और इसकी संभावना पर पुनर्जीवित किया जाएगा drm-buf काम जो मुख्य रूप से लिनारो के माध्यम से एआरएम दुनिया से बाहर आ गया है। एक बार यह सब ऊपर और चल रहा है - जो एक वर्ष से 6 महीने दूर लगता है - हाइब्रिड ग्राफिक्स को सही तरीके से करना संभव होगा। उस बिंदु पर एनवीडिया पराक्रम लिनक्स पर ऑप्टिमस का समर्थन करने पर पुनर्विचार, क्योंकि यह अब लागू करने के लिए एक बड़ी तकनीकी गड़बड़ी नहीं होगी।

हाइब्रिड ग्राफिक्स का समर्थन करने के मामले में अभी व, द भंवरा परियोजना उन पंक्तियों के साथ कुछ करता है। यह अनिवार्य रूप से एनवीडिया कार्ड पर एक दूसरा एक्स सर्वर चलाता है और प्रतिपादन के आउटपुट में प्रतियां चलाता है। यह उतना बुरा नहीं है जितना यह ध्वनि हो सकता है - यह मूल रूप से विंडोज 7 के तहत एनवीडिया कार्ड करता है, बस हार्डवेयर समर्थन के साथ ही।

उबंटू एक्स टीम बम्बलबी या आयरनहाइड (बम्बलबी का कांटा) का समर्थन करने की योजना नहीं बना रही है।

यदि आपके सिस्टम में इंटेल और एनवीडिया कार्ड के बीच स्विच करने के लिए एक BIOS विकल्प है तो आप उनके बीच चयन कर सकते हैं।

यदि आपके सिस्टम में हार्डवेयर मक्स है - इसलिए दोनों एनवीडिया और इंटेल जीपीयू आउटपुट से जुड़े हुए हैं - और vga_swicheroo काम करता है, तो आप उनके बीच स्विच करने के लिए उस इंटरफ़ेस का उपयोग कर सकते हैं, लेकिन केवल तभी जब आप ओपन-सोर्स ड्राइवर का उपयोग कर रहे हों। 12.04 के लिए हम यह सुनिश्चित करने की योजना बना रहे हैं कि इस मामले में अप्रयुक्त जीपीयू बंद कर दिया गया है, जिससे बैटरी जीवन में सुधार होना चाहिए।

यदि आपके सिस्टम में कोई BIOS विकल्प नहीं है और इसमें हार्डवेयर mux नहीं है जो vga_switcheroo जानता है कि ड्राइव कैसे करें, तो आपका एनवीडिया कार्ड 12.04 पर उपयोग योग्य नहीं होगा।

¹: एएमडी है fglrx ड्राइवर को हाइब्रिड ग्राफिक्स के लिए कुछ समर्थन है। ऐसा लगता है कि यह एक एक्स सर्वर होने और इंटेल ड्राइवर को लोड करने का नाटक करके ऐसा करता है। यह एक साफ समाधान नहीं है।


41
2018-06-26 08:06



मुझे लगता है कि प्राइम (डेव का काम) के लिए एक साल अभी भी आशावादी है और दो साल अधिक यथार्थवादी है। ऑप्टिमस जैसी तकनीकें पूर्ण सॉफ़्टवेयर समाधान हैं, हार्डवेयर समर्थन प्रदान नहीं करता है, विंडोज 7 के तहत भी नहीं। जबकि बम्बलबी एक सही समाधान नहीं है, संस्करण 3.0 डिफ़ॉल्ट रूप से पावर सेविंग जोड़ता है। उसमें इसके बारे में अधिक जानकारी askubuntu.com/a/36936/6969 - Lekensteyn
ऑप्टिमस नहीं है एक पूर्ण सॉफ्टवेयर समाधान; एनवीडिया जीपीयू में मदद करने के लिए कुछ हार्डवेयर हैं (नोव्यू प्रोजेक्ट पीसीओपीवाई इंजन कहता है), हालांकि यह सिर्फ एक प्रदर्शन अनुकूलन है। मैं, जाहिर है, ऐसा नहीं लगता कि एक वर्ष है बहुत प्राइम के लिए असंभव वीआरएएम से कॉपी करने की तुलना में ऑप्टिमस वास्तव में अधिक परिष्कृत नहीं है। यह मुख्य रूप से एक्स सर्वर का डिज़ाइन है जिसने इसे कठिन बना दिया है। - RAOF
वह मेरे दिमाग से फिसल गया। मेरा मुद्दा यह था कि स्विचिंग कार्यक्षमता पूरी तरह से सॉफ्टवेयर में लागू होती है और हार्डवेयर उस पर मदद नहीं करता है ("muxless") - Lekensteyn
सही। यह पूरी तरह से सच है। मेरा मुद्दा एक नाइटपिक का थोड़ा सा था; हार्डवेयर पूरी तरह से एक अनुकूलन है। - RAOF
12.10, आरएओएफ के लिए आपके अपडेट के लिए धन्यवाद, लेकिन क्या आप नवीनतम उबंटू के समर्थन पर थोड़ा सा विस्तार कर सकते हैं? मैं एनवीडिया ऑप्टिमस का उपयोग कर रहा हूं और मैं नहीं देख रहा हूं, उदाहरण के लिए, एनवीडिया चिपसेट से जुड़ा एक डीवीआई पोर्ट एक्सेस करने के लिए कुछ भी। - Ken Kinder


आपका लैपटॉप है एनवीडिया - ऑप्टिमस सक्षम होना चाहिए। बिजली बचाने के लिए यह एक दोहरी ग्राफिक्स विन्यास है। वर्तमान में एनवीडिया लिनक्स में इस तकनीक के लिए कोई समर्थन प्रदान नहीं करता है। तो लिनक्स में दोनों ग्राफिक्स कार्ड हैं जिन पर नेतृत्व होता है उच्च बैटरी खपत और अति गर्म। अधिक जानकारी के लिए नीचे सूचीबद्ध लिंक पढ़ें।

ऑप्टिमस तकनीक में, इंटेल ग्राफिक्स हमेशा चालू रहता है। जब आप GT540M का उपयोग करते हैं, तो GT540M द्वारा उत्पन्न छवियों को इंटेलिजेंट इंटेल ग्राफिक्स कार्ड के माध्यम से वितरित किया जाता है।

लिनक्स में विकल्प उपलब्ध हैं

एनवीडिया जीटी 540 एम बंद करें और केवल इंटेल का उपयोग करें। आवश्यक होने पर केवल विशेष कमांड के साथ एनवीडिया कार्ड का उपयोग करें। Also never install nvidia-drivers alone.

स्थापित करने के लिए निर्देश भंवरा अलग GPU को बंद करने और केवल आवश्यक होने पर सक्षम करने के लिए

  1. टर्मिनल में निम्नलिखित टाइप करें,

    sudo add-apt-repository ppa:bumblebee/stable
    

    फिर

    sudo apt-get update
    
  2. मालिकाना nvidia चालक का उपयोग कर Bumblebee स्थापित करने के लिए:

    sudo apt-get install bumblebee bumblebee-nvidia linux-headers-generic
    
  3. रीबूट।


यदि आप सिर्फ एनवीडिया कार्ड को अक्षम करना चाहते हैं, तो अनुवर्ती सीखने की कोई आवश्यकता नहीं है

उपयोग निर्देश:

एनवीडिया कार्ड के साथ एक प्रोग्राम चलाने के लिए, उपयोग करें optirun टर्मिनल में prefixed कमांड। चलाने के लिए पसंद है glxspheres एनवीडिया कार्ड प्रकार के साथ। हालांकि एक गुई विधि भी मौजूद है।

optirun glxspheres

फ़ायरफ़ॉक्स प्रकार चलाने के लिए:

optirun firefox &

ध्यान दें: यदि आप शराब जैसे 32-बिट प्रोग्राम चलाने और उबंटू 11.10 का उपयोग करना चाहते हैं तो वन्यिक या बाद में, 32-बिट लाइब्रेरी इंस्टॉल करें:

sudo apt-get install virtualgl-libs:i386 libgl1-mesa-glx:i386 libc6:i386

जुड़े प्रश्न:

ऑप्टिमस नोटबुक पर एनवीडिया कार्ड / ड्राइवर का उपयोग नहीं कर सकता


13
2018-04-26 14:56



हैलो वेब-ई मैं उन आदेशों को डालने की कोशिश कर रहा था, जिन्हें आपने मुझे टर्मिनल में बताया था जब मैंने सूडो एपीटी-गेट इंस्टॉल बम्बलबी बम्बलबी-एनवीडिया में रखा था, मुझे मोहम्मद @ मोहम्मद-एस्पायर -3830 टीजी मिला: ~ $ sudo apt-get bumblebee bumblebee इंस्टॉल करें -nvidia पैकेज सूची पढ़ना ... हो गया बिल्डिंग निर्भरता पेड़ राज्य की जानकारी पढ़ना ... हो गया ई: पैकेज बम्बेबी का पता लगाने में असमर्थ ई: पैकेज बम्बेबी-एनवीडिया का पता लगाने में असमर्थ यह सुनिश्चित नहीं है कि इसका क्या अर्थ है। - Mohamed Ahmed
मुझे लगता है कि आपने दूसरे चरण को छोड़ दिया है sudo apt-get update । इसे पहले चलाने दें। फिर पुन: प्रयास करें। अगर यह फिर से विफल रहा है। मुझे बताएं - Web-E


NVIDIA ऑप्टिमस है नहीं वर्तमान यूनिक्स प्लेटफार्मों पर किसी भी तरह से समर्थित है।

यह विशेष रूप से किसी भी लैपटॉप (मोबाइल) एनवीआईडीआईए आधारित प्रणाली के लिए है जो ऑप्टिमास को इसकी विनिर्देश सूची में कहता है। आप अपने उबंटू में एनवीआईडीआईए ग्राफिक्स का भी उपयोग नहीं कर पाएंगे। आपको एकीकृत इंटेल ग्राफिक्स ड्राइवरों के साथ काम करने की आवश्यकता होगी (जिस हद तक वे आपके प्लेटफ़ॉर्म के लिए समर्थित हैं - सैंडी ब्रिज समर्थन अभी भी कमजोर है)।

यह ध्यान दिया जाना चाहिए कि ऑप्टिमस एकीकृत (आमतौर पर इंटेल) और अलग (एनवीआईडीआईए, एटीआई) ग्राफिक्स सिस्टम के बीच स्विच करने की पुरानी क्षमता से अलग है। ऑप्टिमस के साथ, एकीकृत ग्राफिक्स पथ हमेशा उपयोग में होता है और आपको आवश्यकतानुसार (अतिरिक्त) असतत ग्राफिक्स को सक्षम करने देता है - यह ज़रूरत फिलहाल विंडोज 7 (afaik, Vista पर भी काम नहीं करेगा)।

इस पर गति प्राप्त करने के लिए यहां कुछ संदर्भ दिए गए हैं।

  1. UbuntuForums: एनवीडिया ऑप्टिमस और उबंटू ने समझाया 
  2. Phoronix: क्या एनवीआईडीआईए ऑप्टिमस अनिवार्य रूप से लिनक्स में आएगा?
    25 अप्रैल, 2011 को माइकल लैराबेल द्वारा पोस्ट किया गया 

संकेत: मैं एक एक्सपीएस 15 एल 502 एक्स का उपयोग करता हूं 525 एम ऑप्टिमस असतत ग्राफिक्स।  


अद्यतन करें: यह एक उद्धरण है एनवीआईडीआईए ड्राइवर्स 270.06 में पृष्ठ Additional Information टैब।

समर्थित जीपीयू को शामिल करने वाले कुछ डिज़ाइन एनवीआईडीआईए लिनक्स ड्राइवर के साथ संगत नहीं हो सकते हैं: विशेष रूप से, स्विचबुक (हाइब्रिड) या ऑप्टिमस ग्राफिक्स के साथ नोटबुक और ऑल-इन-वन डेस्कटॉप डिज़ाइन काम नहीं करेंगे यदि हार्डवेयर में एकीकृत ग्राफिक्स को अक्षम करने का अर्थ उपलब्ध नहीं है ।

अब आप जानते हैं कि अपने नए एनवीआईडीआईए आधारित लैपटॉप चश्मे में क्या देखना है यदि आप एनवीआईडीआईए को लिनक्स से ड्राइव करना चाहते हैं।


अद्यतन: देखो भौंरा-परियोजना
से शुरू करें README क्या आप वहां मौजूद हैं।


9
2017-11-22 18:48





वर्तमान में वहाँ है भंवरा एनवीडिया ऑप्टिमस का समर्थन करने के लिए।

मेरे पास इंटेल कोर i5 (अंतर्निहित इंटेल ग्राफिक्स के साथ) और एक एनवीडिया 420 एम ग्राफिक्स कार्ड के साथ एक डेल अक्षांश E6520 है। आप के साथ एक कार्यक्रम चला सकते हैं optirun (प्रकार optirun programname एक टर्मिनल शुरू करने के लिए programname) और फिर यह एनवीडिया ग्राफिक्स का उपयोग करने में सक्षम हो जाएगा।

मैंने इसे सीयूडीए कार्यक्रमों के साथ नहीं किया है।


4
2017-09-01 02:57





Nvidia ड्राइवर काम नहीं करेंगे क्योंकि ग्राफिक्स कार्ड का चयन करने के लिए डेल में BIOS विकल्प नहीं है। बम्बेबी की स्थिर रिलीज आज़माएं। यह कल मेरे लिए एक डेल l502x (525M कार्ड) पर काम किया और मैंने कई बार रिबूट करने के बाद सत्यापित किया। डिफ़ॉल्ट रूप से इंटेल का उपयोग किया जाएगा लेकिन आप आदेश ऑप्टिअन द्वारा NVIDIA का उपयोग कर अनुप्रयोग चला सकते हैं। इसके अलावा आपको बूटिंग के बाद बम्बेबी को फिर से शुरू करना होगा।


2
2017-10-18 01:59





मुझे लगता है कि एनवीडिया ऑप्टिमस 11.10 और 11.04 दोनों पर आयरनहाइड के साथ ठीक काम करता है। मुझे लगता है कि एक ऑप्टिमस लैपटॉप खरीदने के लिए कोई सलाह pedantic और overbearing है। लिनक्स लैपटॉप 24x7 पर ग्राफिक्स राक्षस चलाने की आवश्यकता कौन है? इंटेल जीपीयू बिजली पर बहुत बेहतर है और जहां तक ​​मैं कह सकता हूं, आयरनहाइड एनवीडिया जीपीयू नहीं चलाता जब तक आप ऑप्टिरुन का आह्वान नहीं करते। मैं अपने ऑप्टिमस लैपटॉप से ​​बहुत खुश हूं।

बाहरी मॉनीटर के लिए उचित समर्थन की कमी (मुझे 1080i रिज़ॉल्यूशन नहीं मिल सकता) एक सैंडी ब्रिज इंटेल एचडी 3000 मुद्दा है जिसे मैं भरोसा करता हूं बाद में रिलीज में सॉर्ट किया जाएगा। इस मुद्दे के पास ऑप्टिमस के साथ कुछ लेना देना नहीं है और सभी इंटेल एचडी 3000 लैपटॉप पर मौजूद होगा।

यह गाइड डेल एक्सपीएस 17 एल 702 एक्स लैपटॉप और वनिरिक के लिए है, लेकिन मेरा मानना ​​है कि इसे अधिकांश ऑप्टिमस लैपटॉप के लिए काम करना चाहिए।

ऊपर दिए गए लिंक का पालन करने से पहले सभी एनवीडिया ड्राइवरों को हटाना सुनिश्चित करें, और शुभकामनाएँ!


2
2018-05-24 23:16



इंटेल वेब साइट में वे दावा करते हैं कि एचडी ग्राफिक्स 3000 2560 एक्स 1600 तक आउटपुट कर सकता है। माई डेल एक्सपीएस 15 एल 502 एक्स मिनीडिस्प्लेपोर्ट के माध्यम से 1 9 00X1080p बाहरी मॉनीटर से जुड़ा हुआ है। लेकिन मैं यह नहीं बता सकता कि यह 1080i या 1080p आउटपुट कर रहा है या नहीं। आप इसके बारे में कैसे यकीन कर सकते हैं? आपका क्या मतलब है (मुझे 1080i नहीं मिल सकता है)? मेरा ext.monitor 1 9 00X1080 60 हर्ट्ज पीपी दिखा रहा है (स्रोत: इंटेल एचडी 3000)। - Hanynowsky


बम्बलबी समाधान आपको एक ही समय में एकीकृत कार्ड और असतत एनवीडिया ऑप्टिमास कार्ड दोनों चलाने की अनुमति देता है। फिर acpi_call और byo-switcheroo आपके विशिष्ट लैपटॉप मॉडल के आधार पर असतत ग्राफिक्स कार्ड को चालू / बंद करने के लिए विभिन्न तंत्र प्रदान करते हैं। अतीत में की तुलना में चीजें अब अपेक्षाकृत बेहतर समर्थित हैं, इस पर एक नज़र डालें: http://launchpad.net/~hybrid-graphics-linux


1
2017-12-19 11:56



यह ऑप्टिमस सिस्टम के साथ काम नहीं करता है। वर्तमान में, यूनिक्स / लिनक्स सिस्टम के लिए वर्तमान में कोई भी उपलब्ध ड्राइवर ऑप्टिमस सिस्टम पर सही ढंग से काम नहीं करता है। - Thomas Ward♦
acpi_call अब bbswitch के पक्ष में बहिष्कृत है। - Lekensteyn


लिनक्स को अपनाने से लोगों को वापस लाने में एक बड़ी समस्या इस प्रकार की हार्डवेयर समस्या है। मैं एक दीर्घकालिक उबंटू उपयोगकर्ता और समर्थक हूं जो इस तरह की खरीद के साथ गलती नहीं कर सकता। मैं यह जानने के लिए £ 500 + खर्च नहीं करना चाहता हूं कि मेरे पास ग्राफिक्स त्वरण नहीं है क्योंकि विंडोज 7 एक विकल्प नहीं है।

यदि आप दीर्घकालिक लिनक्स उपयोगकर्ता हैं तो आपको समझना चाहिए कि हार्डवेयर संगतता हार्डवेयर निर्माताओं पर निर्भर करती है। हमें इस नई तकनीक को अपनाने के लिए कुछ समय लिनक्स / कर्नेल समुदाय देना होगा। आखिर में जो कुछ भी हमारे पास है, वह किसी भी अन्य ओएस की तुलना में लिनक्स में वास्तव में प्रतिस्पर्धी सीपीयू प्रबंधन है। लेकिन इसमें समय लगता है।

मेरे दोस्त को धीरज रखो


1
2018-05-31 23:14



सच है, यह आमतौर पर समय की बात है - पहले ब्रॉडकॉम ड्राइवरों, वाईफ़ाई ग्लिच, आदि के साथ, और अब ग्राफिक्स कार्ड के साथ। - NoBugs