सवाल एलटीएस से अगले में अपग्रेड करते समय "कोई नई रिलीज नहीं मिली" क्यों है?


मैं पीछा कर रहा हूँ उबंटू की वेबसाइट पर निर्देशों को अपग्रेड करें, लेकिन अपग्रेड टूल लॉन्च करने पर मुझे यह प्रतिक्रिया मिलती है:

Checking for a new ubuntu release
No new release found

क्या मुझसे कुछ गलत हो रही है? क्या आसपास कोई काम है?


214
2018-04-26 14:26


मूल




जवाब:


उबंटू इंजीनियरिंग फाउंडेशन टीम मैनेजर स्टीव लैंगसेक के मुताबिक:

एलटीएस रिलीज के बीच उन्नयन डिफ़ॉल्ट रूप से जुलाई के लिए निर्धारित पहली बिंदु रिलीज, 14.04.1 तक सक्षम नहीं है। यह अनुशंसा की जाती है कि अधिकांश एलटीएस उपयोगकर्ता तब तक 14.04 तक अपग्रेड करने से पहले प्रतीक्षा करें।

यदि आप पहले अपग्रेड करना चुनते हैं, तो आप पास कर सकते हैं -d अपग्रेड टूल का विकल्प, चल रहा है do-release-upgrade -d या update-manager -d, वेनिला 12.04 से 14.04 तक अपग्रेड करने के लिए। (-वेल के लिए खड़े हो जाओ)

यह प्रश्न प्रॉम्प्ट के इंतजार के लिए औचित्य बताता है।


225
2018-04-26 17:33



फिर, फिर से-रिलीज-अपग्रेड (डीडी के बिना) अभी भी कह रहा है कि 1oo फॉर्म में रिलीज़ होने के कुछ दिन बाद "कोई नई रिलीज नहीं मिली"? (मेरा / आदि / अपडेट-मैनेजर / रिलीज-अपग्रेड कहता है "प्रॉम्प्ट = एलटीएस") - tudor
कोड के निरीक्षण से, ऐसा लगता है कि "सामान्य" एक यूआरएल को डिफ़ॉल्ट रिलीज करता है changelogs.ubuntu.com/meta-release जो 14.04 सूचीबद्ध करता है, और एलटीएस रिलीज यूआरएल का उपयोग करता है changelogs.ubuntu.com/meta-release-lts जो इसे बिल्कुल सूचीबद्ध नहीं करता है। मुझे लगता है कि उन्होंने अभी तक मेटा जानकारी अपडेट नहीं की है। - tudor
यह रिलीज निरीक्षण की तरह लगता है, क्या आप एक बग और सीसी फाइल कर सकते हैं? ईमेल मेरी प्रोफाइल में है, धन्यवाद! - Jorge Castro
@JorgeCastro क्या यह वास्तव में एक रिलीज निरीक्षण है, और क्या यह कोई विचार है जब इसे ठीक किया जाएगा? एक बग दायर किया गया था, और मैं इसका अनुसरण कहां कर सकता हूं? (मैंने खोज की, लेकिन इसे नहीं मिला। मैं भी 12.04 एलटीएस से 14.04.1 एलटीएस में स्विच करना चाहता हूं, और मैं इसे अद्यतन प्रबंधक के माध्यम से करना चाहता हूं।) - Marnix Klooster
जैसा दिखता है changelogs.ubuntu.com/meta-release-lts अब तय है - DLosc


अगर किसी के पास जीयूआई तक कोई पहुंच नहीं है और टर्मिनल पर अपडेट चाहता है:

  1. फ़ाइल संपादित करें

    /etc/update-manager/release-upgrades
    

    के लिये Prompt या तो मैच करने के लिए normal या lts। (नीचे दिए गए सूची को देखें जो आपके मामले में फिट बैठता है, ध्यान रखें कि आप केवल एलटीएस को दूसरे एलटीएस संस्करण में अपग्रेड कर सकते हैं):

    [DEFAULT]
    Prompt=normal
    
  2. परीक्षण सही संस्करण मिला है, चलाओ

    do-release-upgrade -c
    
  3. सही संस्करण दिखाए जाने पर अपग्रेड करें:

    sudo do-release-upgrade -d
    

इस तरह से मैं 12.04 से 12.10 तक अपग्रेड कर सकता हूं।

उपलब्ध Prompt विकल्प हैं:

  • कभी नहीं - एक नई रिलीज की जांच न करें।
  • सामान्य - यह देखने के लिए जांचें कि कोई नई रिलीज उपलब्ध है या नहीं। यदि एक से अधिक नई रिलीज मिलती है, तो रिलीज अपग्रेडर अपग्रेड करने का प्रयास करेगा   रिलीज के लिए जो तुरंत वर्तमान में चल रहा है सफल   रिहाई।
  • एलटीएस - यह देखने के लिए जांचें कि कोई नई एलटीएस रिलीज उपलब्ध है या नहीं। अपग्रेडर के बाद उपलब्ध पहली एलटीएस रिलीज में अपग्रेड करने का प्रयास करेगा   वर्तमान में चल रहा है। ध्यान दें कि यदि इस विकल्प का उपयोग नहीं किया जाना चाहिए   वर्तमान में चल रही रिलीज खुद ही एक एलटीएस रिलीज नहीं है, क्योंकि इसमें से   अगर अपग्रेडर यह निर्धारित करने में सक्षम नहीं होगा कि कोई नई रिलीज है या नहीं   उपलब्ध।

67
2018-05-05 16:50



मेरा मुद्दा भी ऐसा ही था। मैं बस प्रॉम्प्ट = सामान्य से प्रॉम्प्ट = lts में बदल गया और यह मेरे लिए बस ठीक काम किया। - sir_k
फ्लोरिन का वर्णन करने के लिए मुझे विपरीत समस्या मिली। 4-21-18 पर, उबंटू 14.04 एलटीएस 'प्रॉम्प्ट = एलटीएस' से 'प्रॉम्प्ट = सामान्य' में बदलने तक 'कोई नई रिलीज नहीं मिली' कह रही थी। इसे अपग्रेड करने के लिए 16.04 एलटीएस चुना गया, जो मैं चाहता था। मुझे कोई जानकारी नहीं है की क्यों। - Chris Dragon


sudo do-release-upgrade -d 

अंत में डीडी नोटिस; वहाँ से man पृष्ठ:

  -d, --devel-release
      If using the latest supported release, upgrade to the development release

यह भी काम करता है Prompt=lts में /etc/update-manager/release-upgrades


19
2018-04-26 17:55



प्रश्न में वर्णित जैसा ही था ... - antivirtel


2 विकल्प:

  1. आईएसओ को जलाएं और इसे अपने ड्राइव में रखें, यह स्वचालित रूप से अपग्रेड का पता लगाएगा

  2. आप synaptics विकल्पों में जाओ, फिर वरीयता> वितरण> हमेशा उच्चतम संस्करण पसंद करते हैं।

समस्या सुलझ गयी ?


3
2018-04-28 02:15



धन्यवाद, धन्यवाद। :) मुझे यह महसूस करने के लिए बेवकूफ लगता है। - CullenDM
10.04 रिलीज तुरंत अपग्रेड नहीं होंगे, ऊपर दिए गए लिंक को देखें। - Jorge Castro