सवाल क्या एफएफएमपीजी 14.04 में आधिकारिक भंडारों से गायब है?


मैंने भरोसेमंद / उबंटू 14.04 में ffmpeg स्थापित करने का प्रयास किया और निम्न संदेश प्राप्त किया:

$sudo apt-get install ffmpeg

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package ffmpeg is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'ffmpeg' has no installation candidate

पैकेज उपलब्ध क्यों नहीं है?


289
2018-03-11 04:14


मूल


आउटपुट क्या है: एपीटी-कैश खोज ffmpeg | grep "ffmpeg" अगर आप नहीं देखते हैं ffmpeg लौटाए गए परिणामों की सूची में, तो आपके रेपो मैनेजर के साथ कुछ गलत हो गया है। अभी के लिए, मैं स्रोत से निर्माण करके स्थापित करने का सुझाव दूंगा। वहाँ से डाउनलोड यहाँ। - wyas
ध्यान दें कि 2018 तक, avconv ffmpeg में नहीं है, और libav-tools उबंटू भंडार में नहीं है! - Owl


जवाब:


ताज़ा खबर


एफएफएमपीईजी और लिबव

उबंटू भंडार से libav

उबंटू ने शिपिंग शुरू कर दिया libav के बदले कांटा FFmpeg में हालिया रिलीज। अगर आपने स्थापित किया है ffmpeg पैकेज, तो आप वास्तव में स्थापित किया libav-tools पैकेज और एक कार्यक्रम जिसने आपको उपयोग करने के लिए कहा था avconv के बजाय ffmpeg भविष्य में, इंप्रेशन दे रहा है कि ffmpeg को बहिष्कृत किया गया है, जो यह नहीं है।

संक्रमणकालीन ffmpeg लगता है कि पैकेज भरोसेमंद / उबंटू 14.04 से हटा दिया गया है (तुलना करें पैकेज फाइलें सॉसी और भरोसेमंद के लिए लिस्टिंग स्रोत पैकेज)।

तो एक विकल्प libav-tools संकुल को संस्थापित करना और उपयोग करना है avconv इसके बजाए (एनबी कि यह "मुख्य रेखा" एफएफएमपीईजी नहीं बल्कि इसके बजाय एक प्रमुख कांटा है)।

लॉन्चपैड पर एक पीपीए से एफएफएमपीजी

एक और विकल्प एक पीपीए का उपयोग करना है जो एफएफएमपीईजी प्रदान करता है। कृपया एक नज़र डालें एफएफएमपीईजी डाउनलोड करें उपलब्ध पीपीए और पैकेज के विवरण के लिए पेज। यदि आप अभी भी अद्यतित हैं तो आपको प्रत्येक बार व्यक्तिगत पीपीए की जांच करनी चाहिए।

संबंधित सवाल:

स्रोत से स्थापित करें

एक अन्य विकल्प FFmpeg निर्भरता पैकेज स्थापित करना है, फिर मैन्युअल रूप से संकलित करें + इसे स्रोत से इंस्टॉल करें।

स्थिर निर्माण का प्रयोग करें

हालांकि यह पैकेजिंग परिप्रेक्ष्य से थोड़ा अजीब लग सकता है, आप किसी भी स्थिर निर्माण का उपयोग भी कर सकते हैं भरोसा सूत्रों का कहना है। मेरे मामले में मैं एफएफएमपीईजी विंडोज 32-बिट और 64-बिट बाइनरी को x264-10-बिट बाइनरी के साथ एक फ़ोल्डर में शराब या विंडोज़ में चलाने के लिए रखता हूं जब भी मुझे आवश्यकता होती है।


इस विषय पर शोध करते समय, मुझे यह मिल सकता है। मैं दोनों परियोजनाओं के विकास के साथ निकटता से पालन नहीं कर रहा हूं और किसी को दोष देने का मेरा इरादा नहीं है। आप एक पाठक के रूप में या तो नहीं करना चाहिए।

कांटा कैसे हुआ?

विकिपीडिया का कहना है कि 13 मार्च 2011 को फोर्कड परियोजना के साथ-साथ प्रारंभिक रिलीज की घोषणा की गई थी, हालांकि कुछ और चल रहा था।

गिट के माध्यम से खुदाई करता है

  • 18 जनवरी 2011 - प्रतिबद्ध f4f5cab94e0881cd30965b28f3d78d9c63d6918e

    एफएफएमपीजी परियोजना के नेता माइकल निडेरमेयर को हटा दिया गया है MAINTAINERS फ़ाइल।

  • 27 जुलाई 2011 - प्रतिबद्ध 6291d7e41605c0b1e9debfae8a2b1d4cf7b0e0b3

    avconv शुरू किया है:

    एक नए नाम के तहत ffmpeg की एक प्रति बनाएं - avconv।

    इसे कुछ असंगत परिवर्तनों के साथ और विकसित किया जाएगा।

    ffmpeg.c कुछ समय के लिए रहेगा, इसलिए इसका उपयोग करने वाली कोई भी स्क्रिप्ट नहीं होगी   टूटा हुआ।

  • 27 जुलाई 2011 - प्रतिबद्ध 791a86c37a03b94207bc2d0ad4cbe7f39d7e495a

    कांटा संस्करण में एक चेतावनी जोड़ा गया है ffmpeg.c स्रोत कोड, जो उन उपयोगकर्ताओं को भ्रामक हो सकता है जिन्होंने कांटा के बारे में ध्यान नहीं दिया है और वे अब एफएफएमपीईजी का उपयोग नहीं कर रहे हैं।

  • 12 जनवरी 2012 - प्रतिबद्ध 0fec2cb15cc6ff1fcc724c774ec36abadcb7b6ad

    ffmpeg.c स्रोत कोड से हटा दिया गया है।

Libav.org पर आधिकारिक घोषणाएं

निम्नलिखित पोस्ट समाचार अनुभाग से हैं (आखिरी में सबसे पुराने के साथ):

अगस्त 09 2011

12.09.2011 को अपडेट किया गया।

हमारे नए नाम के साथ स्थिरता के लिए हमने नाम बदल दिया है ffplay सेवा मेरे avplay,    ffserver सेवा मेरे avserver तथा ffprobe सेवा मेरे avprobe। उनका व्यवहार है   वही, बस नाम बदल दिए गए थे।

साथ में ffmpeg (कमांड लाइन उपकरण) हमने इस अवसर का उपयोग करने का फैसला किया   कुछ लंबी उपयोगिता समस्याओं को ठीक करने के लिए, जिसमें तोड़ना शामिल है   संगतता। इसलिए हमने नाम का एक नया टूल जोड़ा है avconv कौन कौन से   पर आधारित है ffmpeg, लेकिन एक अलग है (उम्मीद है कि अधिक शक्तिशाली और   उपयोग करने में आसान) कुछ विकल्पों के लिए वाक्यविन्यास। ffmpeg इसमें रखा जाएगा   कुछ समय के लिए वर्तमान स्थिति, इसलिए इसका उपयोग करने वाली कोई स्क्रिप्ट या फ्रंटेंड नहीं होगा   टूटना। हालांकि इसे और विकसित नहीं किया जाएगा।

बीच के भेद avconv तथा ffmpeg इस प्रकार हैं:

[...]

ध्यान दें कि avconv इंटरफेस अभी तक स्थिर नहीं माना जाता है। अधिक   असंगत परिवर्तन अगले हफ्तों में आ सकते हैं। हम घोषणा करेंगे   यहाँ कब avconv स्थिर है

और 2011 में पहले:

18 मार्च, 2011

हमने अपनी 0.6 रिलीज शाखा से एक और बिंदु रिलीज को धक्का दिया है:    लीब 0.6.2। यह एक और रखरखाव-केवल रिलीज दो को संबोधित करता है   सुरक्षा मुद्दे।

अब से, हम अपने नए प्रोजेक्ट नाम का उपयोग करेंगे libav। लेकिन मत करो   चिंता, पिछली रिलीज 0.6.1 की तुलना में, केवल कार्यात्मक   परिवर्तन वीसी 1 और एपीई डिकोडर्स के लिए दो सुरक्षा सुधार हैं। इस   इसका मतलब है कि libav मौजूदा के लिए एक दर्द रहित ड्रॉप-इन प्रतिस्थापन प्रदान करता है   एफएफएमपीईजी इंस्टॉलेशन।

इसके अलावा, हमें इस स्रोत रिलीज के साथ गर्व है   निष्पादन योग्य और पुस्तकालयों के लिए win32 मंच। ये बाइनरी   बंडल x264 लाइब्रेरी का उपयोग कर H.264 एन्कोडिंग शामिल करें। का आनंद लें!

वितरक और सिस्टम इंटीग्रेटर्स को अद्यतन और साझा करने के लिए प्रोत्साहित किया जाता है   हमारी रिलीज शाखाओं के खिलाफ उनके पैच।

17 मार्च, 2011

हमने अपनी 0.5 रिलीज शाखा से एक और बिंदु रिलीज को धक्का दिया है:    एफएफएमपीजी 0.5.4। यह एक और रखरखाव-केवल उस पते को छोड़ देता है   कई सुरक्षा मुद्दों।

वितरक और सिस्टम इंटीग्रेटर्स को अद्यतन और साझा करने के लिए प्रोत्साहित किया जाता है   हमारी रिलीज शाखाओं के खिलाफ उनके पैच।

13 मार्च, 2011

हम, एफएफएमपीजी डेवलपर्स के एक समूह के रूप में, जारी रखने का फैसला किया है   लिबाव नाम के तहत एफएफएमपीजी विकसित करना। सभी मौजूदा बुनियादी ढांचे   libav.org डोमेन में स्थानांतरित कर दिया जाएगा।

आप निम्न आदेश का उपयोग कर अपने गिट भंडार को अद्यतन कर सकते हैं:

git remote set-url origin 'git://git.libav.org/libav'

अभी के लिए हम अभी भी एफएफएमपीईजी की मेलिंग सूचियों और आईआरसी पर पहुंच योग्य हैं   चैनल लेकिन हम libav.org समकक्षों में माइग्रेट करेंगे। के लिए   संक्रमण अवधि दोनों वेबसाइट और स्रोत में अभी भी हो सकता है   एफएफएमपीईजी के संदर्भ। यह कहां छोड़कर, समय के साथ गायब हो जाएगा   ऐतिहासिक रूप से प्रासंगिक।

24 फरवरी, 2011

एफएफएमपीजी विकास गिट में स्थानांतरित हो गया है, और एसवीएन भंडार संख्या है   अब अपडेट किया गया। एसवीएन भंडार को निकट भविष्य में हटाया जा सकता है, इसलिए   आपको एक का उपयोग करने की अनुशंसा की जाती है गिट भंडार बजाय।

2011-01-19 को एसवीएन के लिए प्रतिबद्ध अंतिम संशोधन r26402 था और   एक स्टैंडअलोन प्रति के साथ svn: बाहरी libswscale बदल दिया।

ध्यान दें कि एफएफएमपीजी विकास वास्तव में अब तक एक गिट भंडार में स्थानांतरित हो गया है और दो गिट भंडार हैं। इसी परियोजनाओं को डाउनलोड पेज देखें।


258
2018-03-11 06:39



यह परिवर्तन कब हुआ? - Seth♦
@ सेठ क्या आपका मतलब एफएफएमपीईजी के बजाय libav शिपिंग या संक्रमणकालीन पैकेज छोड़ना है? मुझे एक मेल मिला जो तकनीकी बोर्ड से एक टीम रिपोर्ट को इंगित करता है और लॉन्चपैड पर स्रोत पैकेज के लिए एक लिंक भी जोड़ता है जहां कोई सॉसी और भरोसेमंद पैकेज लिस्टिंग की तुलना कर सकता है, लेकिन मुझे विवरण नहीं पता। - LiveWireBT
मैं पैकेज छोड़ने का जिक्र कर रहा था, हालांकि यदि संभव हो तो मैं दोनों के लिए समय-फ्रेम में रूचि रखता हूं। - Seth♦
मैं पीपीए से अंत तक ffmpeg स्थापित करने के तरीके को स्थानांतरित कर सकता हूं। एक "यदि आप वास्तव में ज्वार के खिलाफ तैरने के लिए हैं, और आप इन सभी चीजों को पहले ही पढ़ चुके हैं ... तो आप यह कर सकते हैं।" मोर्चे पर इसे सभी तरह से डालने के बजाय। जैसे, यदि आप पीपीए से बच सकते हैं तो चीजों का उपयोग मुख्य / यूनी / बहु में कर सकते हैं। - RobotHumans
@ hbdgaf मैंने जोड़ा askubuntu.com/q/35629 एक सिर के रूप में। एफएफएमपीजी पीपीए पहले से ही आखिरी था, नए जोड़े गए इतिहास खंड पर विचार नहीं कर रहा था। शुद्ध राजनीति (और शायद नफरत) के बजाय, मैं नई डिंटरटरलेस फ़िल्टर जैसी विभिन्न कार्यक्षमताओं पर चर्चा करना चाहता हूं w3fdif एफएफएमपीईजी में (लेकिन यह इस प्रश्न के लिए ऑफ-विषय है)। मुझे समझ में नहीं आ रहा है कि मैं स्पष्ट रूप से क्यों समझा रहा हूं (मैं विशेष रूप से आपको दोष नहीं दे रहा हूं)। मुझे इन परियोजनाओं में से किसी एक के साथ कोई संबद्धता नहीं है और जितना संभव हो उतना उद्देश्य बनने का इरादा है। - LiveWireBT


ffmpeg द्वारा पिछले रिलीज में बदल दिया गया था avconv libav परियोजना से कार्यक्रम।

स्थापित करने के लिए avconv आपको स्थापित करने की आवश्यकता है libav-tools पैकेज:

sudo apt-get install libav-tools

avconv बहुत समान है ffmpeg, लेकिन उनमें वाक्यविन्यास में कुछ अंतर भी हैं।

संपादित करें: ऐसा लगता है कि उबंटू 16.04 एलटीएस फिर से है ffmpeg अपने भंडारों में, इसलिए libav-tools एक डमी पैकेज है और केवल उपनाम बनाता है avconv -> ffmpeg (और दूसरे)


120
2018-04-07 08:11



आसान उत्तर लेकिन सभी दिशानिर्देश ऑनलाइन कहते हैं कि सामान करने के लिए ffmpeg का उपयोग कैसे करें, avconv नहीं, और यही मुझे इस पृष्ठ पर लाया। रूटस के लिए माफ़ी के साथ: शून्य एक। - शायद अगर आप मतभेदों को समझाते हैं, तो हम इसके साथ काम करने में सक्षम होंगे। - Aaron Hall
@ aaron-hall मुझे लगता है कि आपका -1 अनुचित है। आप कुछ गलत उम्मीद करते हैं। 2014 में किए गए सवाल बहुत स्पष्ट हैं: क्या यह 14.04 में गायब है? और जवाब हां है, कुछ पिछले संस्करणों में ffmpeg जितना अधिक avconv के लिए केवल एक उपनाम था। इससे कोई फर्क नहीं पड़ता कि आप क्या खोज रहे थे। हो सकता है कि आप इस पृष्ठ पर क्लिक करने से पहले पृष्ठ के शीर्षक को न पढ़ें। लेकिन चिंता न करें, मैं 184 प्रतिष्ठा वाले लोगों के लिए एक अस्वीकरण के साथ संपादित करूंगा जो काम नहीं करता है कि कैसे कार्य करता है। - Rutrus
मेरे पास अभी भी 14.04 है, और मैं ffmpeg का उपयोग करना चाहता हूं - क्या avconv एक ड्रॉप-इन प्रतिस्थापन है या क्या? क्या अंतर हैं? - Aaron Hall
व्यापक बहुमत तुंहारे इस साइट पर प्रतिनिधि इस उत्तर के कारण है, जिसे मैं आधारित लिखा था केवल शीर्ष जवाब में सामग्री पर। तुम चौंक गए कमाना आपका प्रतिनिधि एक सभ्य उत्तर लिखकर कहता है, कम से कम संक्षेप में और आम तौर पर मतभेद क्या हैं। हाथ से चलना समय की बर्बादी है। जब तक यह वास्तव में केवल एक उपनाम नहीं है, इस स्थिति में वाक्यविन्यास में कोई अंतर नहीं होना चाहिए। और यदि आप करते हैं, तो आप उत्तर की मेरी राय को उलट देंगे, लेकिन जैसा कि वर्तमान में यह खड़ा है, यह स्वयं विरोधाभास करता है! मुझे बताएं कि जब मैं इन टिप्पणियों को हटा सकता हूं। - Aaron Hall
libav-tools ffmpeg से एक कांटा है। ffmpeg द्वारा प्रतिस्थापित किया गया था avconv उबंटू रिपोज़ में 2012 से 2014 तक। आप इस नए प्रश्न को अपने उत्तर के लिए पूछ सकते हैं, या खुद को ढूंढो। आप उबंटू 15.04 के बाद से ffmpeg का फिर से उपयोग कर सकते हैं। सार: libav ffmpeg वाक्यविन्यास के साथ संगत है, लेकिन विपरीत में नहीं है। - Rutrus


ffmpeg libav के बजाय उबंटू के रेपो हटा दिया था। आपको पीपीए जोड़ना चाहिए:

sudo add-apt-repository ppa:mc3man/trusty-media
sudo apt-get update
sudo apt-get install ffmpeg gstreamer0.10-ffmpeg

अपना आउटपुट देखें


47
2018-04-20 07:13



यह होना चाहिए: 'सुडो ऐड-एपीटी-रिपोजिटरी पीपीए: एमसी 3man / ट्रस्टी-मीडिया :) इसे संपादित नहीं कर सकता है, पर्याप्त वर्ण नहीं बदला गया है। - IndexOutOfBoundsException
यह वर्तमान आधिकारिक पीपीए के रूप में FFmpeg.org पर सूचीबद्ध पीपीए नहीं है। (पीपीए को बनाए रखने वाला प्रोजेक्ट सदस्य भी बदल सकता है, यही कारण है कि मैंने एक निश्चित पीपीए जोड़ने के निर्देशों को शामिल करने का फैसला नहीं किया।) यदि आप इस पीपीए को देखते हैं तो यह केवल ffmpeg की तुलना में एक बहुत अधिक पैकेज अपडेट करता है। - LiveWireBT
यह अब और काम नहीं करता है। - MadeOfAir
यह वास्तव में कारगर है। मैंने अभी यह पीपीए जोड़ा है और अब मैं एफएफएमपीईजी स्थापित कर रहा हूं। - Muhammad bin Yusrat
@LiveWireBT (और अन्य) कि पीपीए अब उबंटू लिंक के रूप में प्रदान किया गया है एफएफएमपीईजी डाउनलोड पेज... - Wilf


आप इस पीपीए का भी उपयोग कर सकते हैं: पीपीए: जॉन-severinsson / ffmpeg

संपादित करें: यह पीपीए लॉन्चपैड से हटा दिया गया है, मुझे नहीं पता क्यों। इसके बजाय, आप इसका उपयोग कर सकते हैं samrog131 पीपीए (भरोसेमंद, उष्णकटिबंधीय और विशद के लिए)

sudo add-apt-repository ppa:samrog131/ppa
sudo apt-get update
sudo apt-get install ffmpeg-set-alternatives

पीपीए में ऐसे अन्य पैकेज भी शामिल हैं जिन्हें आप नहीं चाहते हैं। स्थापना के बाद पीपीए निकालें।

sudo add-apt-repository --remove ppa:samrog131/ppa
sudo apt-get update

44
2018-04-30 08:15



फिक्स्ड एपीटी-एड-रिपॉजिटरी -> ऐड-एपीटी-रिपोजिटरी। यदि apt-add-repository अब आपके लिए काम नहीं करता है, तो इसे आजमाएं: stackoverflow.com/questions/13018626/... - RedPixel
यह मूल रूप से वही जानकारी है जो मैंने अपने उत्तर में पोस्ट की है, लेकिन चेतावनी के बिना जो उपयोगकर्ताओं को पीपीए से पैकेज स्थापित करने के लिए सलाह देने से पहले हमेशा दिया जाना चाहिए। इसके अलावा संभावना है कि कोई और भविष्य में एफएमपीईपीजी पीपीए के रखरखाव को ले जाएगा या पीपीए को अभी ले जाया जाएगा या उसका नाम बदल दिया जाएगा। इसलिए आधिकारिक निर्देशों को जोड़ना सही तरीका है, क्योंकि यह अनावश्यकता और रखरखाव के प्रयास को कम करता है। - LiveWireBT
यह GStreamer-ffmpeg एकीकरण प्रदान नहीं करता है। @ डुओंग का जवाब (mc3manपीपीए) करता है। - Victor Sergienko
यह पीपीए यूटोपिक का समर्थन नहीं करता है। - Amir Ali Akbari
और अब यह पीपीए हटा दिया गया था। - MFern


कुछ समय से डेबियन भंडारों से एफएफएमपीईजी पैकेज हटा दिया गया था। अभी भी एक है जारी वाद - विवाद भंडार में पैकेज को फिर से शामिल करने के बारे में। उबंटू डेबियन व्युत्पन्न के रूप में, अपस्ट्रीम के निर्णयों पर निर्भर करता है। बहुत समय पहले, पैकेज libav की निर्भरता के साथ बस खाली था। यह 12 मई 2012 में बदल दिया गया था जब पैकेज को हटा दिया गया था और अभिलेखागार से हटा दिया गया था:

libav (6:0.8.99-1537-gacb2c79-1) experimental; urgency=low

  * New upstream snapshot
    - Drop patches applied upstream
    - Longer build libpostproc, dropped upstream
    - follow soname bump of libavcodec and libavformat 53->54
    - New library: libswresample
  * no longer build and use dirac, removed upstream in favor of libschroedinger
  * remove deprecated ffmpeg package
  * bump shlibs version

 -- Reinhard Tartler <siretart@tauware.de>  Sat, 12 May 2012 22:02:03 +0200

8
2018-04-04 02:00



यह मत कहें कि यह खाली था, सॉसी में पैकेज में बाइनरी होती है dpkg --contents ffmpeg_0.8.7-1ubuntu2_amd64.deb [...] -rwxr-xr-x root/root 106624 2013-10-11 10:41 ./usr/bin/ffmpeg। - LiveWireBT
@LiveWireBT क्या आप अकेले पैकेज का उपयोग कर सकते हैं? वह एकल फ़ाइल avconv बाइनरी को जोड़ने के लिए सिर्फ एक बाइनरी थी। संक्रमणकालीन पैकेज हमेशा खाली पैकेज के रूप में समझा जाता है। - Braiam
हम सिर्फ एक ही बात सोच रहे हैं और एक-दूसरे को गलत समझ रहे हैं। :) - LiveWireBT


चलाने की कोशिश करते समय मुझे एक ही त्रुटि थी

sudo apt-get install ffmpeg

इसलिए मैंने कुछ अन्य उत्तरों, साथ ही साथ सामग्री को भी जोड़ा इस साइट, मेरे लिए काम करने वाली निम्नलिखित नुस्खा प्राप्त करने के लिए:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:mc3man/trusty-media  # ignore warning if not found
sudo add-apt-repository ppa:mc3man/trusty-media
sudo apt-get update
sudo apt-get dist-upgrade

sudo apt-get install ffmpeg

अब मैं देख सकता हूं कि ffmpeg स्थापित किया गया है:

sudo find / -type f -name "ffmpeg"

रिटर्न /opt/ffmpeg/bin/ffmpeg

बैश प्रॉम्प्ट से, कमांड ffmpeg अब किसी भी फ़ोल्डर से काम करना चाहिए।


3
2018-01-28 19:45



dist-upgrade स्थापित करने के लिए आवश्यक नहीं है ffmpeg - Raptor


यदि आप उबंटू 14.04 में ffmpeg 2.2.1 (स्रोत से) स्थापित करना चाहते हैं, तो आप इसे निम्न विकल्पों का उपयोग करके आज़मा सकते हैं:

64-बिट ओएस के लिए:

निर्भरता की सूची:

yasm frei0r-plugins-dev gnutls-bin libgnutls-dev libass-dev libgsm1-dev libmp3lame-dev libopencv-dev libopenjpeg-dev libopus-dev libpulse-dev libschroedinger-dev libsoxr-dev libspeex-dev libtheora-dev libv4l-dev libvorbis-dev libvpx-dev libx264-dev libxvidcore-dev libopenal-dev libcdio-paranoia-dev

संकलन विकल्प:

./configure --prefix=/usr --bindir=/usr/bin --datadir=/usr/share/ffmpeg --incdir=/usr/include/ffmpeg --libdir=/usr/lib/x86_64-linux-gnu/  --mandir=/usr/share/man --arch=x86_64 --optflags='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic' --enable-bzlib --disable-crystalhd --enable-frei0r --enable-gnutls --enable-libass --enable-libcdio --enable-libdc1394 --disable-indev=jack --enable-libfreetype --enable-libgsm --enable-libmp3lame --enable-openal --enable-libopencv --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libvorbis --enable-libv4l2 --enable-libvpx --enable-libx264 --enable-libxvid --enable-x11grab --enable-avfilter --enable-avresample --enable-postproc --enable-pthreads --disable-static --enable-shared --enable-gpl --disable-debug --disable-stripping --shlibdir=/usr/lib/x86_64-linux-gnu/ --enable-runtime-cpudetect

32 बिट ओएस के लिए:

निर्भरता की सूची:

yasm frei0r-plugins-dev gnutls-bin libgnutls-dev libass-dev libgsm1-dev libmp3lame-dev libopencv-dev libopenjpeg-dev libopus-dev libpulse-dev libschroedinger-dev libsoxr-dev libspeex-dev libtheora-dev libv4l-dev libvorbis-dev libvpx-dev libx264-dev libxvidcore-dev libopenal-dev libcdio-paranoia-dev libopencore-amrwb-dev libopencore-amrnb-dev

संकलन विकल्प:

./configure --prefix=/usr --libdir=/usr/lib --shlibdir=/usr/lib --mandir=/usr/share/man --enable-runtime-cpudetect --enable-gpl --enable-version3 --enable-postproc --enable-avfilter --enable-pthreads --enable-x11grab --enable-vdpau --disable-avisynth --enable-frei0r --enable-libdc1394 --enable-libgsm --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-librtmp --enable-libspeex --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxvid --extra-cflags='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4 -grecord-gcc-switches -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables' --disable-stripping  

अधिक जानकारी के लिए मेरा देखें यूट्यूब वीडियो


1
2018-04-20 11:24



AMD64 ?? के लिए साझा किए गए भवन का सुझाव क्यों दें, वहां कुछ हासिल नहीं किया जा सकता है और उन साझा ऐप्स पर निर्भर अन्य ऐप्स तोड़ सकता है। - doug


यदि आप नवीनतम रिलीज को जीथब से ताजा छोड़ना चाहते हैं जो यूट्यूब-डीएल से उत्पन्न त्रुटियों की पसंद को पूरा करता है

ERROR: ffprobe or avprobe not found. Please install one.

फिर इन cmds जारी करें:

sudo apt-get build-dep ffmpeg

git clone https://github.com/FFmpeg/FFmpeg.git

cd FFmpeg

./configure   --build-suffix=-ffmpeg --toolchain=hardened --libdir=/usr/lib/x86_64-linux-gnu --incdir=/usr/include/x86_64-linux-gnu --enable-gpl --enable-shared --disable-stripping --enable-avresample --enable-avisynth --enable-frei0r --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopenjpeg --enable-openal --enable-libopus --enable-libpulse --enable-librtmp --enable-libschroedinger --enable-libshine --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libxvid --enable-libzvbi --enable-opengl --enable-x11grab --enable-libdc1394 --enable-libiec61883 --enable-libzmq --enable-libssh --enable-libsoxr --enable-libx264 --enable-libopencv --enable-libx265

make -j8
sudo make install

का आनंद लें,


0
2018-03-11 04:26