सवाल अपग्रेड के बाद वर्चुअल बॉक्स में वीएम शुरू नहीं कर सकता


मैंने अभी अपग्रेड किया है 13.10 और अब, वर्चुअल बॉक्स मुझे अब मेरी आभासी मशीन शुरू करने नहीं देगा। यह मुझे निष्पादित करने के लिए कहता है /etc/init.d/vboxdrv setup लेकिन अगर मैं करता हूं, तो मुझे निम्न मिलता है:

# /etc/init.d/vboxdrv setup
 * Stopping VirtualBox kernel modules                                                                                                                                       [ OK ] 
 * Uninstalling old VirtualBox DKMS kernel modules                                                                                                                                 Error! Could not locate dkms.conf file.
File:  does not exist.
                                                                                                                                                                            [ OK ]
 * Trying to register the VirtualBox kernel modules using DKMS                                                                                                                     Error! Bad return status for module build on kernel: 3.11.0-14-generic (x86_64)
Consult /var/lib/dkms/vboxhost/4.1.24/build/make.log for more information.

 * Failed, trying without DKMS
 * Recompiling VirtualBox kernel modules                                                                                                                                           
 * Look at /var/log/vbox-install.log to find out what went wrong
root@regDesktopHome:/lib/modules/3.11.0-14-generic/build/include/linux#

और लॉग फ़ाइल में मैं देखता हूं:

    echo >&2 "  ERROR: Kernel configuration is invalid.";           \
    echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
    echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it.";      \

मैं यह कैसे तय कर सकता हूं? कृपया सलाह दें!


1
2017-12-12 04:58


मूल


क्या आपने चल रहे कर्नेल के लिए dkms और शीर्षलेख स्थापित किए हैं? - Terry Wang
@ टेरी वैंग स्पष्ट रूप से नहीं, लेकिन उन्हें अपग्रेड किया जाना चाहिए था, साथ ही मैं उम्मीद करता हूं .. dkms का प्रयास करना मुझे बताता है dkms is already the newest version. - तो यह तदनुसार अपग्रेड हो गया, अरे? लेकिन अब मैं स्थापित कर रहा हूँ virtualbox-dkms - देखें कि क्या मदद करता है ... - cerr


जवाब:


स्थापित कर रहा है virtualbox-dkms और चल रहा है /etc/init.d/vboxdrv setup फिर इस मुद्दे को हल किया!


2
2017-12-16 03:25