सवाल उबंटू 12.10 से 13.04 को अपग्रेड करने में समस्याएं


मैं अपनी उबंटू रिलीज को 12.10 से 13.04 तक अपग्रेड करने की कोशिश कर रहा हूं, जिसने सफलतापूर्वक 12.10 तक सफलतापूर्वक अपग्रेड किया है। इसके बाद 13.10 पर जाने के इरादे से।

मैं अन्य सॉफ्टवेयर अपडेट के साथ अद्यतित हूं।

अद्यतन प्रबंधक का उपयोग करके मुझे रिलीज को अपग्रेड करने की पेशकश की गई है, लेकिन यह अपेक्षित 13.04 के बजाय 13.10 पर अपग्रेड कर रहा है।

अपग्रेड का चयन करते समय यह वास्तव में 13.10 'सॉसी' में अपग्रेड करने का प्रयास करता है, एप्लिकेशन मुझे ऐसा करने के लिए कहता है, ठीक है, और मुझे दूर भेजता है।

कोई विचार है कि मैं पहली बार 13.04 में कैसे अपग्रेड कर सकता हूं?


1
2017-12-17 23:15


मूल


यदि आपको 13.10 की पेशकश की जा रही है तो आपको 13.04 पर होना चाहिए। आप अप्रत्याशित भंडार को सक्षम करने के अपने रास्ते से बाहर निकलने तक अपग्रेडिंग को रोकने के लिए, कुछ समय के लिए जीवन के अंत और असमर्थित होने पर, दोनों को 1010 से सीधे अपग्रेड नहीं कर सकते हैं। - psusi
हाय psusi, आपकी प्रतिक्रिया के लिए धन्यवाद। खेद है कि पहले गलत तरीके से सलाह दी गई है, मैं वास्तव में 12.10 पर हूं, प्रदान की गई रिलीज जानकारी के बाद टर्मिनल पर चेक किया गया है: वितरक आईडी: उबंटू विवरण: उबंटू 12.10 रिलीज: 12.10 कोडनाम: क्वांटल - Lee


जवाब:


आपको उपयोग करना है update-manager-core से quantal-updates के बजाय quantal-proposed

देख: मुझे नहीं पता कि 12.10 से 13.04 या 13.10 को अपग्रेड कैसे करें


1
2017-12-20 15:48



एंड्रियास - आपके उत्तर के लिए धन्यवाद, एक इलाज किया। अद्यतन-प्रबंधक-कोर का उपयोग करके सुझाए गए अनुसार 13.04 को अपडेट किया गया। फिर 13.10 अपडेट-मैनेजर के माध्यम से। बहुत धन्यवाद। - Lee


इसके आस-पास की निश्चित स्थिति यह है कि अद्यतन-प्रबंधक पैकेज सॉसी के उन्नयन का समर्थन नहीं करता है .. ठीक है, आज के रूप में।

शायद यह अतीत में ऐसा किया था, और शायद यह भविष्य में फिर से ऐसा कर सकता है। लेकिन अप्रैल 2014 तक यह उपकरण सॉसी के उन्नयन का समर्थन नहीं करता है। शायद यह ईओलिंग ऑफ रियरिंग (13.04) के कारण हो सकता है .. और शायद 12.10 से 13.10 तक प्रत्यक्ष अपग्रेड की आवश्यकता भी हो सकती है।

मेरे लिए काम करने वाली एकमात्र चीज थी:

  • एस / क्वांटल / सॉसी / /etc/apt/sources.list में
  • एपीटी-अपडेट अपडेट करें
  • एपीटी-डिस्ट-अपग्रेड प्राप्त करें

1
2018-04-15 11:57





यह आपको क्या करना चाहिए:

sudo apt-get -y dist-upgrade

यह आपकी सभी निर्भरता फ़ाइलों को अपग्रेड करेगा, सॉसी को अपग्रेड करने से पहले इस तरह से आसान। यह अगला आदेश आपको सॉसी तक जाने में सक्षम करेगा:

sudo do-release-upgrade

तो वह प्रक्रिया को बंद कर देगा। सौभाग्य!


0
2017-12-17 23:25



हाय फारन, प्रतिक्रिया के लिए जयकार। मैंने इसका प्रयास किया है लेकिन सूडो डू-रिलीज-अपग्रेड के बाद त्रुटि संदेश लौटाया गया है (पीएस मैंने गलत तरीके से सलाह दी है कि मैं वर्तमान में किस संस्करण पर था): अपग्रेड नहीं कर सकता 'क्वांटल' से 'सॉसी' में अपग्रेड इस के साथ समर्थित नहीं है उपकरण। - Lee


यह उम्मीद है, लेकिन इतनी जल्दी नहीं। जनवरी 2014 से दुर्लभ ईओएल (जीवन का अंत) होगा, लेकिन क्वांटल (जो आप उपयोग कर रहे हैं) अभी भी अप्रैल 2014 तक समर्थित रहेगा। तो, रिलीज टीम ने क्या किया:

तो इसके बजाय समर्थित अपग्रेड पथ जनवरी से शुरू होने पर 12.10-> 13.10-> 14.04 होगा।

आप इसे महसूस कर रहे हैं। वे शायद (मुझे अभी तक स्रोत नहीं मिला है) इसे हाथ से पहले सर्वर से सक्रिय किया गया है। मुझे नहीं पता कि इस तरह के व्यवहार को tweaked (क्लाइंट साइड से) किया जा सकता है और मैं इसके साथ प्रयोग नहीं करेंगे। यदि आप काम करते हैं, तो आप अपग्रेड का प्रयास कर सकते हैं, बढ़िया! यदि ऐसा नहीं होता है, तो कृपया एक बग की रिपोर्ट करें। उन्नयन से पहले अपने सभी सामान का बैकअप बनाना सुनिश्चित करें!

सम्बंधित:


0
2017-12-18 21:58



हाय ब्रायम ने अपग्रेड और त्रुटि लौटाई: ली @ ली-एस्पायर -5720: ~ $ सुडो डू-रिलीज-अपग्रेड एक नई उबंटू रिलीज के लिए जांचना प्राप्त करें: 1 अपग्रेड टूल हस्ताक्षर [1 9 बी] प्राप्त करें: 2 अपग्रेड टूल [1,135 केबी ] 0s (0 बी / एस) में 1,135 केबी प्राप्त हुआ 'saucy.tar.gz' के खिलाफ 'saucy.tar.gz.gpg' को प्रमाणित करें 'saucy.tar.gz' निकालने के लिए कैश पढ़ना पैकेज प्रबंधक की जांच करना अपग्रेड नहीं कर सकता 'क्वांटल 'टू' सॉसी 'इस उपकरण के साथ समर्थित नहीं है। - Lee
"क्वांटल 'से' सॉसी 'तक अपग्रेड इस उपकरण के साथ समर्थित नहीं है"मुझे लगता है कि यह समस्या हो सकती है। इसके बजाय अद्यतन-प्रबंधक के साथ प्रयास करें। - Braiam
अद्यतन प्रबंधक को अपग्रेड करने का प्रयास करते समय एक ही त्रुटि प्रदर्शित कर रहा है। यह दिखाता है कि मैं 12.10 पर हूं, एक नया संस्करण 13.10 उपलब्ध है लेकिन फिर यह त्रुटि देता है। मैं इस तरह से हल करने के लिए कोई भीड़ में नहीं हूं, इसलिए जेनरी तक तब तक लटका होगा जब 13.04 आधिकारिक तौर पर ईओएल और असफल हो। 13.10 पर एक साफ इंस्टॉल करें - Lee
@ ब्रायम कृपया मेरा जवाब यहां देखें: askubuntu.com/questions/390587/... एक समाधान के लिए "इस उपकरण के साथ समर्थित नहीं है" मुद्दा। - intgr


मुझे एक ही समस्या थी और इस तरह मैंने 13.10 के बजाय 12.10 से 13.04 को अपग्रेड करने में कामयाब रहा:

1) ओपन रिलीज-अपग्रेड फ़ाइल: sudo gedit /etc/update-manager/release-upgrades
2) आपके पास होना चाहिए Prompt=normal, यह मोड रिलीज करने के लिए अपग्रेड करता है जो वर्तमान में चल रहे रिलीज़ को तुरंत सफल करता है।
3) का उपयोग कर उन्नयन चलाएं sudo do-release-upgrade

इस तरह अब मेरे पास 13.04 है, 13.10 नहीं।


0
2018-01-29 12:27