सवाल उबंटू एसडीके स्थापित करने में असमर्थ


स्थापित करते समय sudo apt-get install ubuntu-sdk, मुझे इसका सामना करना पड़ रहा है निम्नलिखित पैकेजों में अनमेट निर्भरताएं हैं:

ubuntu-sdk : Depends: qtcreator-plugin-ubuntu-cordova but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

1
2017-12-27 19:57


मूल


के संभावित डुप्लिकेट पीपीए जोड़ने के बाद मैं अनमेट निर्भरताओं को कैसे हल करूं? - Tim


जवाब:


ubuntu-sdk निर्भर करता है qtcreator-plugin-ubuntu-cordova। लेटर की जरूरत है cordova-ubuntu-2.8, cordova-ubuntu-2.8-dev, qtcreator-plugin-ubuntu, qtcreator-plugin-ubuntu-cordova-common

यह अनमेट निर्भरता समस्या जागृत हो सकती थी, क्योंकि qtcreator-plugin-ubuntu-cordova स्थापित नहीं किया जा सकता है।

तो भागो:

sudo apt-get install ubuntu-sdk qtcreator-plugin-ubuntu-cordova cordova-ubuntu-2.8 cordova-ubuntu-2.8-dev qtcreator-plugin-ubuntu qtcreator-plugin-ubuntu-cordova-common

2
2017-12-27 20:46