सवाल एलटीएस रिलीज के जीवन के अंत के बाद पुरानी द्विआधारी और पुस्तकालय जारी रहेगा?


यह उबंटू 12.04 एलटीएस से संबंधित है।

जब पीएचपी 5.3 इस वर्ष के अंत में जीवन के अंत में चला जाता है, तो उबंटू 12.04 PHP 5.3 के साथ जारी रहेगा (बैकपोर्टेड सुरक्षा सुधारों के साथ?) या PHP 5.4 में कोई कदम होगा?


1
2018-01-18 20:00


मूल




जवाब:


यह अनुभाग एलटीएस रिलीज में सॉफ़्टवेयर के संबंध में सामान्य प्रश्न का उत्तर देता है और ईओएल के बाद क्या होता है। यह रिलीज में किसी भी सॉफ्टवेयर पर लागू होता है।

12.04 एलटीएस सर्वर के लिए 5 साल तक एक दीर्घकालिक समर्थित रिलीज है। इसका मतलब यह नहीं है कि 12.04 में शामिल सॉफ़्टवेयर के विशिष्ट संस्करण बाद में रिलीज़ में बाद में मौजूद रहेगा।

12.04 जीवन के अंत तक पहुंचने के बाद, पूरी तरह से कोई गारंटी नहीं है कि किसी भी दिए गए सॉफ़्टवेयर के संस्करण 12.04 में मौजूद होंगे या बाद में रिलीज़ में समर्थित होंगे। यह बहुत संभावना है कि आप जिस सॉफ़्टवेयर को चाहते हैं वह पहले ही रिलीज हो जाएगा, बाद में उबंटू के बाद के रिलीज के समय डेबियन में संस्करण के आधार पर संस्करण रिलीज़ हो गया था।

एलटीएस के जीवनकाल के दौरान, हालांकि, एलटीएस रिलीज में सॉफ़्टवेयर के संस्करण समान रहने की संभावना है, उबंटू के रिलीज में संस्करण बाधाओं के प्रतिबंधों को देखते हुए।


यह अनुभाग PHP 5.3 के बारे में मूल प्रश्न का उत्तर देता है और क्या यह 12.04 ईओएल के बाद समर्थित होगा।

जब तक 12.04 जीवन का अंत नहीं होता है, तब तक इसमें PHP 5.3 होगा।

हालांकि, 12.10 (क्वांटल) के रूप में और बाद में सभी के पास PHP 5.4.x या नया है, और इसके बाद बाकी सब कुछ होगा कि डेबियन में क्या है और PHP अपस्ट्रीम क्या जारी है, 12.04 के बाद, रिपॉजिटरीज़ में कोई PHP 5.3 उपलब्ध नहीं है, हालांकि यह एक पीपीए में उपलब्ध हो सकता है।  और संभवतः सुरक्षा बग के साथ झुकाया जाएगा जो 12.04 ईओएल के समय तय नहीं हैं।

यदि आप उन सभी को पढ़ने के लिए बहुत आलसी थे, तो आपके प्रश्न का उत्तर यह है कि, "नहीं, इस बात की कोई गारंटी नहीं है कि 12.04 के जीवन के अंत में PHP 5.3 उपलब्ध होगा"।  यह बहुत संभव होगा कि 12.04 ईओएल तक, PHP अपस्ट्रीम भी 5.3.x का समर्थन नहीं करेगा, और हम PHP 5.5.x पर स्थिर और PHP 5.4.x के रूप में विरासत के रूप में हो सकते हैं।


2
2018-01-18 20:23



धन्यवाद। मुझे थोड़ा और स्पष्टीकरण दें :) मुझे एक PHP वेबैप के लिए विरासत में विरासत मिली है जो PHP 4 के बाद से चल रहा है। यह PHP के उन्नयन 5.3 के साथ ठीक था। इसमें PHP 5.4 के साथ कई समस्याएं हैं। मैं एक कोड समीक्षा और अद्यतन करने की योजना बना रहा हूं, लेकिन समय एक मुद्दा है। मैं इसे एक स्वयंसेवक के रूप में कर रहा हूं। मुझे आशा है कि मैं वेबपैप को 12.04 बॉक्स पर PHP 5.3 के साथ रख सकता हूं और PHP 5.3 के लिए मार्च 2014 के अंत में कोड समीक्षा / अपडेट करने के लिए अपना टाइमफ्रेम बढ़ा सकता हूं। - user237342
थॉमस टिप्पणी का विस्तार करने के लिए @ user237342, आपके पास 6 महीने हैं, दे या ले लो। - Braiam
@ user237342 यह प्रश्न के दायरे से बाहर है। यदि आपको PHP 5.3 की आवश्यकता है तो आपको PHP 5.3 का उपयोग करने के लिए निरंतर बनाए रखा पीपीए खोजना होगा बाद 12.04 ईओएलएस लेकिन आपको कुछ समय पहले 12.04 ईओएल-आईएनजी की चिंता करने की ज़रूरत है। यही मेरा जवाब बताता है, और यह मूल रूप से किसी भी सॉफ़्टवेयर का उत्तर है जो इस प्रश्न में आता है। यदि आप 12.04 ईओएल के बाद PHP 5.3 रखना चाहते हैं तो आपको मैन्युअल रूप से PHP 5.3 और उसके प्लगइन को मैन्युअल रूप से संकलित और स्थापित करना होगा। - Thomas Ward♦
@ ब्रायम 6 महीने पर यह टिप्पणी पूरी तरह झूठी है। 12.04 रिलीज की तारीख से 5 साल के समर्थन के साथ एक एलटीएस है। अप्रैल 2017 12.04 के लिए ईओएल है। ईओएल तिथियों पर पढ़ें।  यह रिलीज के लिए समर्थन समय अवधि का एक अच्छा ग्राफिकल चित्रण है। - Thomas Ward♦
2017 में 12.04 ईओएल। यह मेरे लिए चिंता नहीं है। मार्च 2014 में PHP 5.3 ईओएल। यह एक चिंता है। ऐप के लिए, मैं मार्च 2014 के बाद कुछ महीनों के लिए PHP 5.3 को बनाए रखना चाहता हूं, अच्छी तरह से 12.04 के जीवनकाल में। इसलिए मेरा मूल सवाल है। - user237342